您的位置:首页 > 其它

HDU 1513 Palindrome (滚动数组lcs,水)

2017-09-03 16:06 483 查看
雷火盘古校园招聘开始!

Palindrome

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 6427    Accepted Submission(s): 2123


Problem Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order
to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.
 

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters
from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

 

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

 

Sample Input

5
Ab3bd

 

Sample Output

2

 

Source

IOI 2000
 

Recommend

linle
 

Statistic | Submit | Discuss | Note
水题,不多说了

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
using namespace std;
const int maxn = 5e3 + 5;
int dp[2][maxn];
char s1[maxn], s2[maxn];
int main()
{
int n;
while(~scanf("%d", &n))
{
memset(dp, 0, sizeof(dp));
scanf("%s", s1+1);
int index = n, cur = 0;
for(int i = 1; i <= n; i++)
s2[index--] = s1[i];
for(int i = 1; i <= n; i++)
{
for(int j = 1; j <= n; j++)
{
if(s1[i] == s2[j])
dp[cur][j] = dp[cur^1][j-1] + 1;
else
dp[cur][j] = max(dp[cur^1][j], dp[cur][j-1]);
}
cur ^= 1;
}
printf("%d\n", n - dp[cur^1]
);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: