您的位置:首页 > 其它

HDU--1213--How Many Tables【并查集】

2017-09-03 13:49 363 查看
Description
Today isIgnatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatiuswants to know how many tables he needs at least. You have to notice that notall the friends
know each other, and all the friends do not want to stay withstrangers. 

One important rule for this problem is that if I tell you A knows B, and Bknows C, that means A, B, C know each other, so they can stay in one table. 

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C canstay in one table, and D, E have to stay in the other one. So Ignatius needs 2tables at least. 
 
Input
The input startswith an integer T(1<=T<=25) which indicate the number of test cases. ThenT test cases follow. Each test case starts with two integers N andM(1<=N,M<=1000). N indicates
the number of friends, the friends aremarked from 1 to N. Then M lines follow. Each line consists of two integers Aand B(A!=B), that means friend A and friend B know each other. There will be ablank line between two cases. 
 
Output
For each testcase, just output how many tables Ignatius needs at least. Do NOT print anyblanks. 
 
Sample Input
 2
5 3
1 2
2 3
4 5
 
5 1
2 5
 
Sample Output
 2
4
 
 

解题思路:找有几个父节点

#include<bits/stdc++.h>
#include<set>
using namespace std;
int father[10010];
int findf(int x)
{
int a=x;
while(x!=father[x])
{
x=father[x];
}
//路径压缩
while(a!=father[a])

9875
{
int z=a;
a=father[a];
father[z]=x;
}
return x;
}
void Union(int a,int b)
{
int x,y;
x=findf(a);
y=findf(b);
if(x!=y)
{
father[x]=y;
}
}
int main()
{
int t,n,m;
cin>>t;
while(t--)
{
cin>>n>>m;
for(int i=1;i<=n;i++)
father[i]=i;
for(int i=0;i<m;i++)
{
int a,b;
cin>>a>>b;
if(findf(a)!=findf(b))
{
Union(a,b);
n--;
}
}
cout<<n<<endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: