您的位置:首页 > 其它

最短路 - C - Heavy Transportation POJ - 1797

2017-09-03 11:28 363 查看
C-Heavy Transportation POJ
- 1797
Background 

Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to
the place where it is needed on which all streets can carry the weight. 
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may
become. But you surely know. 

Problem 
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place)
to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.
Input
The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers
specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.
Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer.
Terminate the output for the scenario with a blank line.
Sample Input
1
3 3
1 2 3
1 3 4
2 3 5
Sample Output
Scenario #1:
4
题意:给出各条路直接的承重,求从1-n走过的车的最大载重。
题解:其实就是求从1-n的最大边权值,使用dijk算法反向求一下,道路的初始值都化为0;注意一下格式多一个空行即可。
AC代码:
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
const int maxn = 1e3+7;
const int inf = 1e9;
int t,n,m;
int a[maxn][maxn];
int vis[maxn];
int length[maxn];
void dijk()
{
for(int i=1;i<=n;i++)
{
length[i]=a[1][i];
vis[i]=0;
}
for(int i=1;i<=n;i++)
{
int u=0;
int v;
for(int j=1;j<=n;j++)
{
if(vis[j]==0&&length[j]>u)
{
u=length[j];
v=j;
}
}
vis[v]=1;
for(int j=1;j<=n;j++)length[j]=max(length[j],min(length[v],a[v][j]));
}
}
int main()
{
scanf("%d",&t);
for(int i=1;i<=t;i++)
{
scanf("%d%d",&n,&m);
for(int j=1;j<=n;j++)
for(int k=1;k<=n;k++)
{
a[j][k]=0;
//  else a[j][k]=inf;
}
for(int j=1;j<=m;j++)
{
int x,y,z;
scanf("%d%d%d",&x,&y,&z);
a[x][y]=a[y][x]=z;
}
dijk();
printf("Scenario #%d:\n",i);
printf("%d\n\n",length
);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: