您的位置:首页 > 大数据 > 人工智能

Pat(A) 1090. Highest Price in Supply Chain (25)

2017-09-03 00:32 399 查看

原题目:

原题链接:https://www.patest.cn/contests/pat-a-practise/1090

1090. Highest Price in Supply Chain (25)

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)– everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one’s supplier in a price P and sell or distribute them in a price that is r% higher than P. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the highest price we can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (<=105), the total number of the members in the supply chain (and hence they are numbered from 0 to N-1); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then the next line contains N numbers, each number Si is the index of the supplier for the i-th member. Sroot for the root supplier is defined to be -1. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the highest price we can expect from some retailers, accurate up to 2 decimal places, and the number of retailers that sell at the highest price. There must be one space between the two numbers. It is guaranteed that the price will not exceed 1010.

Sample Input:

9 1.80 1.00

1 5 4 4 -1 4 5 3 6

Sample Output:

1.85 2

题目大意

有一系列经销商,除了根经销商,每个经销商有且只有一个上级,从上级拿到货之后会比进货价多r%卖出。问最高价会是多少,有几个卖最高价的经销商。

输入数据为经销商数N(经销商标记为0~N-1),最原始价格,比例r

下一行为每个经销商的上级,上级为-1表示根经销商。

解题报告

本题不难,dfs解决,困难的地方就是数据多,数组开不了太大,而且如果对于每个经销商,搜索其下级需要遍历n次,容易超时。

所以解决方案是存储一个经销商有哪些下级,而不是哪个是上级,以此来降低时间复杂度

代码

#include "iostream"
#include "vector"
using namespace std;

vector< vector<int> > G;
vector<int> customer;
int N;
double P;
double r;
double ans;
int level,num,templevel;
int root;

void init(){
cin>>N>>P>>r;
G.resize(N);
customer.resize(N,0);
int x;
for(int i = 0; i < N; i++){
cin>>x;
if(x == -1)
root = i;
else{
customer[x]++;
G[x].resize(customer[x],i);//这里resize只会把增加的空间的值改变,相当于增加了一个位置,并置值为i
}

}
level = templevel = 0;
num = 0;
}

void dfs(int r){
int i,j;
for(i = 0; i < customer[r]; i++){
templevel ++;
dfs(G[r][i]);
templevel --;
}
if(!customer[r]){
if(templevel > level){
level = templevel;
num = 1;
}else if(templevel == level){
num ++;
}
}
}

int main(){
init();
dfs(root);
ans =P;
for(int i =0;i < level; i++)
ans *= 1 + r / 100;
printf("%.2f %d",ans,num);
system("pause");
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: