您的位置:首页 > 其它

An Easy Problem

2017-09-02 13:16 204 查看


An Easy Problem

时间限制:1000 ms  |  内存限制:65535 KB
难度:1

描述    In this problem, you are given two integers L and R, and your task is to calculate the sum of all the number's square between L and R(inclusive).

输入The first line contains an integer T, indicates the number of test case.

The next T lines, each line contains two integers L and R(1≤L,R≤10^5).
输出Print an integer represents the sum.
样例输入
2
1 2
2 4


样例输出
5
29


import java.math.BigInteger;
import java.util.Scanner;

public class Main {

public static void main(String[] args) {
Scanner scanner = new Scanner(System.in);
int times = scanner.nextInt();
while (times-- != 0) {
long start = scanner.nextInt();
long end = scanner.nextInt();
BigInteger result = BigInteger.ZERO;
if (start > end) {
long temp = end;
end = start;
start = temp;
}
for (long i = start; i <= end; i++) {
result = result.add(BigInteger.valueOf(i * i));
}
System.out.println(result);
}
}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: