您的位置:首页 > 其它

hdu 3172 Virtual Friends(加权并查集)

2017-09-01 19:11 459 查看

Virtual Friends

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 9579    Accepted Submission(s): 2793


Problem Description

These days, you can do all sorts of things online. For example, you can use various websites to make virtual friends. For some people, growing their social network (their friends, their friends' friends, their friends' friends' friends, and so on), has become
an addictive hobby. Just as some people collect stamps, other people collect virtual friends. 

Your task is to observe the interactions on such a website and keep track of the size of each person's network. 

Assume that every friendship is mutual. If Fred is Barney's friend, then Barney is also Fred's friend.
 

Input

Input file contains multiple test cases. 

The first line of each case indicates the number of test friendship nest.

each friendship nest begins with a line containing an integer F, the number of friendships formed in this frindship nest, which is no more than 100 000. Each of the following F lines contains the names of two people who have just become friends, separated by
a space. A name is a string of 1 to 20 letters (uppercase or lowercase).
 

Output

Whenever a friendship is formed, print a line containing one integer, the number of people in the social network of the two people who have just become friends.
 

Sample Input

1
3
Fred Barney
Barney Betty
Betty Wilma

 

Sample Output

2
3
4

 

Source

University of Waterloo Local Contest 2008.09
 

Recommend

chenrui

题意:

A B 两人交友 

问朋友圈的大小

因为 多组数据 ,每组数据分为T小组

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<map>
#define N 100002
using namespace std;
map<string,int>m;
int pre
;
int num
;
void init()
{
for(int i=1; i<=N; i++)pre[i]=i,num[i]=1;
}
int Find(int x)
{
if(pre[x]!=x)
return pre[x]=Find(pre[x]);
return x;
}
void Merge(int x,int y)
{
int X=Find(x);
int Y=Find(y);
if(X!=Y)
pre[X]=Y,num[Y]+=num[X];
printf("%d\n",num[Y]);
}
int main()
{
int T;
while(scanf("%d",&T)==1)
{
while(T--)
{
int n;
string a,b;
scanf("%d",&n);
init();
m.clear();
int c=0;
for(int i=1; i<=n; i++)
{
cin>>a>>b;
if(!m[a])
m[a]=++c;
if(!m[b])
m[b]=++c;
Merge(m[a],m[b]);
}
}
}
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: