您的位置:首页 > 其它

POJ2386 Lake Counting简单dfs

2017-09-01 09:05 357 查看
Lake Counting

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 36918 Accepted: 18352
Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure
out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.
Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.
Output

* Line 1: The number of ponds in Farmer John's field.
Sample Input
10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output
3
这题可以说是dfs入门题了,题意是给你一个矩阵,W表示水坑,与它周围一圈的八个格子均算联通,要求总共有几个联通的水坑。

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <algorithm>
/* run this program using the console pauser or add your own getch, system("pause") or input loop */
typedef long long ll;
const int N = 1010;
int n,m;
using namespace std;
char Map

;
void dfs(int x,int y)
{
Map[x][y]='.';//这一步很关键,一定将对dfs到的点改为'.'
for(int dx=-1; dx<=1; dx++)
for(int dy=-1; dy<=1; dy++)//枚举所有的八种可能
{
int a=x+dx,b=y+dy;
if(a>=0&&a<n&&b>=0&&b<m&&Map[a][b]=='W')
dfs(a,b);
}
}
int main()
{

scanf("%d%d",&n,&m);
getchar();
int cnt=0;
for(int i=0; i<n; i++)
{
for(int j=0; j<m; j++)
scanf("%c",&Map[i][j]);
getchar();
}
for(int i=0; i<n; i++)
for(int j=0; j<m; j++)
if(Map[i][j]=='W')//如果存在水坑,就对改点进行dfs
{
dfs(i,j);
cnt++;
}
printf("%d\n",cnt);
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: