您的位置:首页 > 其它

【CUGBACM15级BC第10场 B】hdu 5019 Revenge of GCD

2017-08-31 20:10 344 查看

Revenge of GCD

[align=center]Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2797    Accepted Submission(s): 808
[/align]

[align=left]Problem Description[/align]

In mathematics, the greatest common divisor (gcd), also known as the greatest common factor (gcf), highest common factor (hcf), or greatest common measure (gcm), of two or more integers (when at least
one of them is not zero), is the largest positive integer that divides the numbers without a remainder.

---Wikipedia

Today, GCD takes revenge on you. You have to figure out the k-th GCD of X and Y.
 

[align=left]Input[/align]

The first line contains a single integer T, indicating the number of test cases.

Each test case only contains three integers X, Y and K.

[Technical Specification]

1. 1 <= T <= 100

2. 1 <= X, Y, K <= 1 000 000 000 000

 

[align=left]Output[/align]

For each test case, output the k-th GCD of X and Y. If no such integer exists, output -1.
 

[align=left]Sample Input[/align]

3
2 3 1
2 3 2
8 16 3

 

[align=left]Sample Output[/align]

1
-1
2

 

题意:给你一组数a,b,k让你求出a,b两数中第k大的公约数(它两个的最大公约数是第一个,第二大的是第二个)

首先a,b的公约数是a,b共同因子的相乘,它的最大公约数是所有公共因子相乘,所以,a,b的所有公约数都会被其最大公约数整除,所以判断的时候只需要判断a,b最大公约数的因子即可:

#include <iostream>
#include <set>
#include <map>
#include <stack>
#include <cmath>
#include <queue>
#include <cstdio>
#include <bitset>
#include <string>
#include <vector>
#include <iomanip>
#include <cstring>
#include <algorithm>
#include <functional>
#define PI acos(-1)
#define eps 1e-8
#define inf 0x3f3f3f3f
#define debug(x) cout<<"---"<<x<<"---"<<endl
typedef long long LL;
using namespace std;

LL pp[1000010];
int main()
{
int t;
cin >> t;
while (t--)
{
LL x, y, k;
cin >> x >> y >> k;
LL g = __gcd(x, y), n = 0;
for (LL i = 1; i <= sqrt(g); i++)
{
if (g % i == 0)
{
LL j = g / i;
pp[n++] = i;
if (j != i)
{
pp[n++] = j;
}
}
}
sort(pp, pp + n);
if (k > n)
{
cout << "-1" << endl;
}
else
{
cout << g / pp[k - 1] << endl;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  hdu 数论 枚举