您的位置:首页 > 其它

南阳OJ-题目217:a letter and a number

2017-08-31 18:04 337 查看

题目描术:


a letter and a number

时间限制:3000 ms  |  内存限制:65535 KB
难度:1

描述we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, ... f(Z) = 26, f(z) = -26;

Give you a letter x and a number y , you should output the result of y+f(x).

输入On the first line, contains a number T(0<T<=10000).then T lines follow, each line is a case.each case contains a letter x and a number y(0<=y<1000).
输出for each case, you should the result of y+f(x) on a line
样例输入
6
R 1
P 2
G 3
r 1
p 2
g 3


样例输出
19
18
10
-17
-14
-4

2.运行代码

import j
4000
ava.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;

/*
* Dragon 2017.8.31
* a letter and a number
*/
public class Num_217 {

public static void main(String[] args) throws NumberFormatException, IOException
{
BufferedReader in = new BufferedReader(new InputStreamReader(System.in));
int t=Integer.parseInt(in.readLine());

while(t-->0)
{
String[] input=in.readLine().split(" ");
int letter=input[0].charAt(0);
int number=Integer.parseInt(input[1]);

if(letter>=97 && letter<=122)
System.out.println(number-letter+96);
else
System.out.println(number+letter-64);
}
}

}



                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: