您的位置:首页 > 其它

Hdu 1080 Human Gene Functions(DP)

2017-08-31 13:38 351 查看

Human Gene Functions

Problem Description

It is well known that a human gene can be considered as a sequence, consisting of four nucleotides, which are simply denoted by four letters, A, C, G, and T. Biologists have been interested in identifying human genes and determining their functions, because these can be used to diagnose human diseases and to design new drugs for them.

A human gene can be identified through a series of time-consuming biological experiments, often with the help of computer programs. Once a sequence of a gene is obtained, the next job is to determine its function. One of the methods for biologists to use in determining the function of a new gene sequence that they have just identified is to search a database with the new gene as a query. The database to be searched stores many gene sequences and their functions – many researchers have been submitting their genes and functions to the database and the database is freely accessible through the Internet.

A database search will return a list of gene sequences from the database that are similar to the query gene. Biologists assume that sequence similarity often implies functional similarity. So, the function of the new gene might be one of the functions that the genes from the list have. To exactly determine which one is the right one another series of biological experiments will be needed.

Your job is to make a program that compares two genes and determines their similarity as explained below. Your program may be used as a part of the database search if you can provide an efficient one.

Given two genes AGTGATG and GTTAG, how similar are they? One of the methods to measure the similarity of two genes is called alignment. In an alignment, spaces are inserted, if necessary, in appropriate positions of the genes to make them equally long and score the resulting genes according to a scoring matrix.

For example, one space is inserted into AGTGATG to result in AGTGAT-G, and three spaces are inserted into GTTAG to result in –GT–TAG. A space is denoted by a minus sign (-). The two genes are now of equal length. These two strings are aligned:

AGTGAT-G

-GT–TAG

In this alignment, there are four matches, namely, G in the second position, T in the third, T in the sixth, and G in the eighth. Each pair of aligned characters is assigned a score according to the following scoring matrix.



denotes that a space-space match is not allowed. The score of the alignment above is (-3)+5+5+(-2)+(-3)+5+(-3)+5=9.

Of course, many other alignments are possible. One is shown below (a different number of spaces are inserted into different positions):

AGTGATG

-GTTA-G

This alignment gives a score of (-3)+5+5+(-2)+5+(-1) +5=14. So, this one is better than the previous one. As a matter of fact, this one is optimal since no other alignment can have a higher score. So, it is said that the similarity of the two genes is 14.

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case consists of two lines: each line contains an integer, the length of a gene, followed by a gene sequence. The length of each gene sequence is at least one and does not exceed 100.

Output

The output should print the similarity of each test case, one per line.

Sample Input

2

7 AGTGATG

5 GTTAG

7 AGCTATT

9 AGCTTTAAA

Sample Output

14

21

这道题的意思是一共有两个字符串s1,s2,然后邮一个对应关系的表,问你这两个字符串的匹配值最大是多少,这道题我们的转移方程是 dp[i][j]=max(dp[i-1][j-1]+ans[s1[i]][s2[j]],max(dp[i][j-1]+ans[5][s2[j]],dp[i-1][j]+ans[s1[i]][5]));意思是用了i个s1和j个s2后的最大值,是在s1[i-1][j-1]的基础上把s1[i],s2[j]加上,或者在用了i个s1和j-1个s2后之后用一个‘-’和第j个s2,或者在用了i-1个s1和j个s2后之后用一个‘-’和第i个s1,然后取最大值就好

#include<bits/stdc++.h>
using namespace std;
using LL=int64_t;
const int INF=0x3f3f3f3f;
int ans[6][6]={{0},{0,5,-1,-2,-1,-3},{0,-1,5,-3,-2,-4},{0,-2,-3,5,-2,-2},{0,-1,-2,-2,5,-1},{0,-3,-4,-2,-1,0}};
int dp[105][105];
int main()
{
ios::sync_with_stdio(0);
cin.tie(0);
int T;
cin>>T;
while(T--) {
int len1,len2;
int s1[105],s2[105];
char x;
cin>>len1;
for(int i=1;i<=len1;i++) {
cin>>x;
if(x=='A') s1[i]=1;
else if(x=='C') s1[i]=2;
else if(x=='G') s1[i]=3;
else if(x=='T') s1[i]=4;
}
cin>>len2;
for(int i=1;i<=len2;i++) {
cin>>x;
if(x=='A') s2[i]=1;
else if(x=='C') s2[i]=2;
else if(x=='G') s2[i]=3;
else if(x=='T') s2[i]=4;
}
memset(dp,0,sizeof(dp));
for(int i=1;i<=len2;i++) dp[0][i]=dp[0][i-1]+ans[5][s2[i]];
for(int i=1;i<=len1;i++) dp[i][0]=dp[i-1][0]+ans[s1[i]][5];
for(int i=1;i<=len1;i++){
for(int j=1;j<=len2;j++){
dp[i][j]=max(dp[i-1][j-1]+ans[s1[i]][s2[j]],max(dp[i][j-1]+ans[5][s2[j]],dp[i-1][j]+ans[s1[i]][5]));
}
}
cout<<dp[len1][len2]<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: