您的位置:首页 > 产品设计 > UI/UE

POJ 1458 Common Subsequence(LCS)

2017-08-30 22:33 531 查看
题目链接:http://poj.org/problem?id=1458点击打开链接

Common Subsequence

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 54741 Accepted: 22802
Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ...,
zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with
index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. 

Input
The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces.
The input data are correct.

Output
For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. 

Sample Input
abcfbc         abfcab
programming    contest
abcd           mnp


Sample Output
4
2
0


#include<string>
#include<iostream>
#include<algorithm>
#include<cstring>
#define maxn 1010
using namespace std;
int judge(char a,char b)
{
if(a==b)
return 1;
else
return 0;
}
int dp[maxn][maxn];
int main()
{
string s1,s2;
while(cin >> s1,cin >> s2)
{
memset(dp,0,sizeof(dp));
for(int i=0;i<s1.length();i++)
for(int j=0;j<s2.length();j++)
{
if(judge(s1[i],s2[j]))
dp[i+1][j+1]=dp[i][j]+1;
else
dp[i+1][j+1]=max(dp[i][j+1] , dp[i+1][j] );
}
cout << dp[s1.length()][s2.length()] << endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: