您的位置:首页 > 其它

HDU2717 Catch That Cow

2017-08-30 21:55 218 查看

Problem Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute

Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

思路

给定两个数,n,k,求从n到k所走的次数所少,每次可以加1,或减1或翻倍。

简单bfs。

代码

#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<iostream>
#include<queue>
using namespace std;
long int n, k;
int dir[2] = {-1, 1};
long int t;
long int now;
int visit[100010];
int step[100010];
int bfs()
{
queue<long int> q;
q.push(n);
visit
= 1;

while(!q.empty())
{
t = q.front();
q.pop();
if(t == k)
return 0;
for(int i = 0; i < 3; i++)
{
if(i == 2)
{
now = t * 2;
}
else
now = t + dir[i];

if(now < 0 || now > 100000)
continue;
if(!visit[now])
{
q.push(now);
visit[now] = 1;
step[now] = step[t] + 1;
}
if(now == k)
return step[now];
}
}
return -1;
}
int main()
{

while(scanf("%ld%ld",&n,&k) != EOF)
{
memset(visit, 0, sizeof(visit));
memset(step, 0, sizeof(step));
printf("%d\n",bfs());
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: