您的位置:首页 > 其它

POJ-1742:Coins(多重背包二进制求法)

2017-08-30 14:54 489 查看
Coins

Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 38612 Accepted: 13100
Description

People in Silverland use coins.They have coins of value A1,A2,A3...An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change)
and he known the price would not more than m.But he didn't know the exact price of the watch. 

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins. 

Input

The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by
two zeros.
Output

For each test case output the answer on a single line.
Sample Input
3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output
8
4


思路:多重背包(二进制形式)。注意:不要使用max函数!!!!会TLE!!

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
int v[105],c[105];
int d[100001];
int main()
{
int n,m;
while(scanf("%d%d",&n,&m)!=EOF)
{
if(n==0&&m==0)break;
for(int i=0;i<n;i++)scanf("%d",&v[i]);
for(int i=0;i<n;i++)scanf("%d",&c[i]);
memset(d,0,sizeof d);
for(int i=0;i<n;i++)
{
if(c[i]*v[i]>=m)
{
for(int j=v[i];j<=m;j++)
{
if(d[j-v[i]]+v[i]>d[j])d[j]=d[j-v[i]]+v[i];
}
}
else
{
int k=1;
while(c[i]-k>0)
{
for(int j=m;j>=v[i]*k;j--)
{
if(d[j-v[i]*k]+v[i]*k>d[j])d[j]=d[j-v[i]*k]+v[i]*k;
}
c[i]-=k;
k*=2;
}
for(int j=m;j>=v[i]*c[i];j--)
{
if(d[j-v[i]*c[i]]+v[i]*c[i]>d[j])d[j]=d[j-v[i]*c[i]]+v[i]*c[i];
}
}
}
int ans=0;
for(int i=1;i<=m;i++)ans+=(d[i]==i);
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: