您的位置:首页 > 其它

ZOJ 3203 Light Bulb——(三分求极值)

2017-08-29 19:22 453 查看
传送门

Compared to wildleopard’s wealthiness, his brother mildleopard is rather poor.

His house is narrow and he has only one light bulb in his house.

Every night, he is wandering in his incommodious house, thinking of how to earn more money.

One day, he found that the length of his shadow was changing from time to time while walking between the light bulb and the wall of his house.

A sudden thought ran through his mind and he wanted to know the maximum length of his shadow.



Input

The first line of the input contains an integer T (T≤ 100), indicating the number of cases.

Each test case contains three real numbers H, h and D in one line.
H is the height of the light bulb while h is the height of mildleopard.
D is distance between the light bulb and the wall.
All numbers are in range from 10-2 to 103, both inclusive, and H - h >= 10-2.

Output

For each test case, output the maximum length of mildleopard’s shadow in one line, accurate up to three decimal places..

Sample Input

3
2 1 0.5
2 0.5 3
4 3 4


Sample Output

1.000
0.750
4.000


题目大意:

在图片中,已知 H,h,D 求 L 的最大值

解题思路:



其中在 [0,D∗hH] 区间中, f(x) 为单峰函数。

证明:f′(x)=D∗h−D∗H(x−D)2+1

显然在 [0,D∗hH] 区间中有且只有一个点使得 f′(x)=0 ,那么 f(x) 为极值函数。所以有两种方法来求:

(1)通过三分 [0,D∗hH] 来找极值。

(2)通过公式直接找到极值点对应的 x,其中 x=D−D∗H−D∗h−−−−−−−−−−−√, 然后判断 x 是不是在 [0,D∗hH] 区间中,如果在区间中的话, x 对应的 f(x) 就是极值,否则就特判。

当 x<0,f(x)=h

当 x>D∗hH,f(x)=D∗hH

三分代码:

#include <iostream>
#include <string.h>
#include <string>
#include <algorithm>
#include <stdio.h>
#include <stdlib.h>
#include <math.h>
#include <map>
using namespace std;
typedef long long LL;
const int MAXN = 1e6+5;
const double PI = acos(-1);
const double eps = 1e-8;
const LL MOD = 1e9+7;
double H, h, D;
double f(double x){
double ans = (H*x-D*h)/(x-D)+x;
return ans;
}
double sanfen(double l, double r){
double midl, midr;
while(r-l > eps){
midl = l + (r-l)/3;
midr = r - (r-l)/3;
if(f(midl) >= f(midr)) r = midr;
else l = midl;
}
return f(l);
}
int main(){
//freopen("C:/Users/yaonie/Desktop/in.txt", "r", stdin);
//freopen("C:/Users/yaonie/Desktop/out.txt", "w", stdout);
int T; scanf("%d", &T);
while(T--){
scanf("%lf%lf%lf",&H, &h, &D);
double r = D*h/H;
double ans = sanfen(0, r);
printf("%.3f\n",ans);
}
return 0;
}


公式代码:

#include <iostream>
#include <string.h>
#include <string>
#include <algorithm>
#include <stdio.h>
#include <stdlib.h>
#include <math.h>
#include <map>
using namespace std;
typedef long long LL;
const int MAXN = 1e6+5;
const double PI = acos(-1);
const double eps = 1e-8;
const LL MOD = 1e9+7;
double H, h, D;
double f(double x){
double ans = (H*x-D*h)/(x-D)+x;
return ans;
}

int main(){
//freopen("C:/Users/yaonie/Desktop/in.txt", "r", stdin);
//freopen("C:/Users/yaonie/Desktop/out.txt", "w", stdout);
int T; scanf("%d", &T);
while(T--){
scanf("%lf%lf%lf",&H, &h, &D);
double r = D*h/H;
double x = D-sqrt(D*H-D*h);
double ans = f(x);
if(x > r) ans = D*h/H;
if(x < 0) ans = h;
printf("%.3f\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: