您的位置:首页 > 其它

poj 2253 Frogger(floyd变形)

2017-08-29 16:37 393 查看
Frogger

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 48728 Accepted: 15518
Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her
by jumping. 

Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 

To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 

The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's
stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.
Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line
after each test case, even after the last one.
Sample Input
2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output
Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

Source

Ulm Local 1997

tips:求一条路径上的每次jump的最大值。

然后找到所有从1号石头到2号石头路径上最大值的最小值。

类似floyd。

dis[i][j]代表从第i号石头调到第j号石头的每次jump的最大距离。

动态转移方程:

dis[j][k]=min(dis[j][k],max(dis[j][i],dis[i][k]));

#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
using namespace std;

const int inf=0x3f3f3f3f;

//dis[i][j]代表从第i号石头调到第j号石头的最小步数
int n;
double dis[222][222];
double getd(int x1,int x2,int y1,int y2)
{
return sqrt((x1*1.0-x2)*(x1*1.0-x2)+(y1*1.0-y2)*(y1*1.0-y2));
}
struct node{
int x,y;
};
void init()
{
for(int i=1;i<=n;i++)
{
for(int j=1;j<=n;j++)
{
dis[i][j]=(i==j?0:inf);
}
}
}
node a[222];
void floyd()
{
for(int i=1;i<=n;i++)
{
for(int j=1;j<=n;j++)
{
for(int k=1;k<=n;k++)
{
dis[j][k]=min(dis[j][k],max(dis[j][i],dis[i][k]));
}
}
}
}
int main()
{
int cas;
while(cin>>n,n)
{
cas++;
init();
for(int i=1;i<=n;i++)
{
cin>>a[i].x>>a[i].y;
}

for(int i=1;i<=n;i++)
{
for(int j=1;j<=n;j++)
{
dis[i][j]=getd(a[i].x,a[j].x,a[i].y,a[j].y);
}
}

floyd();
cout<<"Scenario #"<<cas<<endl;
printf("Frog Distance = %.3f\n\n",dis[1][2]);

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: