您的位置:首页 > 产品设计 > UI/UE

Common Subsequence HDU - 1159 (lcs简单dp)

2017-08-29 15:43 405 查看
Problem Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, …, xm> another sequence Z = < z1, z2, …, zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, …, ik> of indices of X such that for all j = 1,2,…,k, xij = zj. For example, Z = < a, b, f, c> is a subsequence of X = < a, b, c, f, b, c> with index sequence < 1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc abfcab

programming contest

abcd mnp

Sample Output

4

2

0

大致题意:求两个串的最长公共子序列长度

思路:简单的dp。假设dp[i][j]表示两个串长度分别为i和j时 的最长公共子序列的长度。如果s1[i]==s2[j],那么dp[i][j]=dp[i-1][j-i]+1,否则dp[i][j]=max(dp[i-1][j],dp[i][j-1]).

代码如下

#include <iostream>
#includ
4000
e <cmath>
#include <algorithm>
#include <cstring>
#include <queue>
#include <cstdio>
#include <map>
using namespace std;
#define ll long long int
char s2[1005];
char s1[1005];
int dp[1005][1005];
int main()
{
while(cin>>s1>>s2)
{
int l1=strlen(s1);
int l2=strlen(s2);
memset(dp,0,sizeof(dp));
for(int i=0;i<l1;i++)
for(int j=0;j<l2;j++)
{
int x=i+1,y=j+1;
if(s1[i]==s2[j])
dp[x][y]=dp[x-1][y-1]+1;
else
dp[x][y]=max(dp[x-1][y],dp[x][y-1]);
}
cout<<dp[l1][l2]<<endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: