您的位置:首页 > 其它

POJ 3071 Football(概率dp+二进制思想)

2017-08-29 14:03 225 查看
Football

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5993 Accepted: 3020
Description

Consider a single-elimination football tournament involving 2n teams, denoted 1, 2, …, 2n. In each round of the tournament, all teams still in the tournament are placed in a list in order of increasing index. Then,
the first team in the list plays the second team, the third team plays the fourth team, etc. The winners of these matches advance to the next round, and the losers are eliminated. After n rounds, only one team remains undefeated; this team is declared
the winner.

Given a matrix P = [pij] such that pij is the probability that team i will beat team j in a match determine which team is most likely to win the tournament.

Input

The input test file will contain multiple test cases. Each test case will begin with a single line containing n (1 ≤ n ≤ 7). The next 2n lines each contain 2n values; here, the jth value
on the ith line represents pij. The matrix P will satisfy the constraints that pij = 1.0 − pji for all i ≠ j, and pii = 0.0 for all i.
The end-of-file is denoted by a single line containing the number −1. Note that each of the matrix entries in this problem is given as a floating-point value. To avoid precision problems, make sure that you use either the 
double
 data type instead
of 
float
.

Output

The output file should contain a single line for each test case indicating the number of the team most likely to win. To prevent floating-point precision issues, it is guaranteed that the difference in win probability for the top two teams will be at least
0.01.

Sample Input
2
0.0 0.1 0.2 0.3
0.9 0.0 0.4 0.5
0.8 0.6 0.0 0.6
0.7 0.5 0.4 0.0
-1

Sample Output
2

Hint

In the test case above, teams 1 and 2 and teams 3 and 4 play against each other in the first round; the winners of each match then play to determine the winner of the tournament. The probability that team 2 wins the tournament in this
case is:

P(2 wins) = P(2 beats 1)P(3 beats 4)P(2 beats 3) + P(2 beats 1)P(4 beats 3)P(2 beats 4)

= p21p34p23 + p21p43p24

= 0.9 · 0.6 · 0.4 + 0.9 · 0.4 · 0.5 = 0.396.
The next most likely team to win is team 3, with a 0.372 probability of winning the tournament.
题意:给你n个队和n个队中两两之间的对阵的胜率,求最可能成为冠军的队伍的胜率

思路:这是单淘汰赛制,所以两队相遇的情况请参考点击打开链接 (((j-1)>>(i-1))^1)==((k-1)>>(i-1)),i代表第i轮比赛,j和k代表两支队伍,胜率的状态方程是dp[i][j]+=dp[i-1][j]*dp[i-1][k]*p[j][k],也就是这一轮的胜率就为上一轮两支队伍的胜率相乘再乘上这一轮要获胜的胜率

#include <iostream>
#include <cstdio>
#include <cstring>
#include <stdio.h>
#include <stdlib.h>
#include <algorithm>
#include <math.h>
using namespace std;
const int maxn=(1<<7)+5;
double p[maxn][maxn];
double dp[maxn][maxn];
int main()
{
int n;
while(scanf("%d",&n)&&n!=-1)
{
int len=1<<n;
for(int i=1;i<=len;i++)
for(int j=1;j<=len;j++)
scanf("%lf",&p[i][j]);
memset(dp,0,sizeof(dp));
for(int i=1;i<=len;i++) dp[0][i]=1;
for(int i=1;i<=n;i++)
for(int j=1;j<=len;j++)
for(int k=1;k<=len;k++)
if((((j-1)>>(i-1))^1)==((k-1)>>(i-1)))
dp[i][j]+=dp[i-1][j]*dp[i-1][k]*p[j][k];
double maxn1=-1;
int ans=1;
for(int i=1;i<=len;i++)
if(dp
[i]>maxn1)
{
maxn1=dp
[i];
ans=i;
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: