您的位置:首页 > 其它

Poj2823 Sliding Window (单调队列)

2017-08-28 21:46 369 查看
超时空传送之术 (能不能别中二了) Time Limit: 12000MS Memory Limit: 65536K

Description

An array of size n ≤ 106 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example:

The array is [1 3 -1 -3 5 3 6 7], and k is 3.



Your task is to determine the maximum and minimum values in the sliding window at each position.

Input

The input consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n integers in the second line.

Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values.

Sample Input

8 3

1 3 -1 -3 5 3 6 7

Sample Output

-1 -3 -3 -3 3 3

3 3 5 5 6 7

题目大意

现在有一堆数字共N个数字(N<=10^6),以及一个大小为k的窗口。现在这个从左边开始向右滑动,每次滑动一个单位,求出每次滑动后窗口中的最大值和最小值。

思路

我们只需要建立一个单调队列,然后判断每次的队首和队尾在不在我们现在的范围内就好了

在的话我们就放在另一个数组里,最后一起输出

#include<cstdio>
#include<algorithm>
int q[1000005],n,k,a[1000005],p[1000005];
void maxq()
{
int head=1,tail=0;
for(int i=1;i<=n;i++)
{
while(head<=tail&&a[i]>=q[tail]) tail--;
q[++tail]=a[i];
p[tail]=i;
while(p[head]<i-k+1) head++;
if(i>=k) printf("%d ",q[head]);
}
printf("\n");
}
void minq()
{
int head=1,tail=0;
for(int i=1;i<=n;i++)
{
while(head<=tail&&a[i]<=q[tail]) tail--;
q[++tail]=a[i];
p[tail]=i;
while(p[head]<i-k+1) head++;
if(i>=k) printf("%d ",q[head]);
}

}
int main()
{
scanf("%d%d",&n,&k);
for(int i=1;i<=n;i++) scanf("%d",&a[i]);
minq(); printf("\n");
maxq();
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj