您的位置:首页 > 产品设计 > UI/UE

HDU - 4027 Can you answer these queries? (线段树区间开根)

2017-08-28 17:25 477 查看


Can you answer these queries?

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)

Total Submission(s): 18877    Accepted Submission(s): 4456


Problem Description

A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease
the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for
help.

You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.

Notice that the square root operation should be rounded down to integer.

 

Input

The input contains several test cases, terminated by EOF.

  For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)

  The second line contains N integers Ei, indicating the endurance
4000
value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 263.

  The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)

  For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query
of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.

 

Output

For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.

 

Sample Input

10
1 2 3 4 5 6 7 8 9 10
5
0 1 10
1 1 10
1 1 5
0 5 8
1 4 8

 

Sample Output

Case #1:
19
7
6

 

Source

The 36th ACM/ICPC Asia Regional
Shanghai Site —— Online Contest

 

Recommend

lcy

题意:给出两种操作, 0 l r 表示 [l , r] 区间上所有数开根号, 1 l r 表示求 [l , r] 区间上所有数的和;

#include <bits/stdc++.h>
using namespace std;

const int N = 1e5 +10;
long long n, m, p = 0;
struct xx{
long long l, r, v, f;
} T[N<<2];

void Pushup(int k){
T[k].v = T[k<<1].v + T[k<<1|1].v;
T[k].f = T[k<<1].f && T[k<<1|1].f;
}

void Build(long long l, long long r, long long k){
T[k].l = l, T[k].r = r, T[k].f = 0;
if(l == r){
scanf("%lld", &T[k].v);
return;
}
int mid = (l+r)>>1;
Build(l, mid, k<<1);
Build(mid+1, r, k<<1|1);
Pushup(k);
}

void Update(long long l, long long r, long long k){
if(T[k].l == T[k].r){
T[k].v = sqrt(T[k].v);
if(T[k].v == 1) T[k].f = 1;
return;
}
int mid = (T[k].l+T[k].r)>>1;
if(l <= mid && !T[k<<1].f) Update(l, r, k<<1);
if(r > mid && !T[k<<1|1].f) Update(l, r, k<<1|1);
Pushup(k);
}

long long ans;
void Query(long long l, long long r, long long k){
if(l <= T[k].l && r >= T[k].r){
ans += T[k].v;
return;
}
if(T[k].l == T[k].r) return;
int mid = (T[k].l+T[k].r)>>1;
if(l <= mid) Query(l, r, k<<1);
if(r > mid) Query(l, r, k<<1|1);
}

int main(){
while(scanf("%lld", &n) == 1){
Build(1, n, 1);
printf("Case #%lld:\n", ++p);
scanf("%lld", &m);
for(int i = 0; i < m; i++){
long long u, v, w;
scanf("%lld%lld%lld", &u, &v, &w);
if(w < v) swap(v, w);
if(!u){
Update(v, w, 1);
}
else{
ans = 0;
Query(v, w, 1);
printf("%lld\n", ans);
}
}
printf("\n");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐