您的位置:首页 > 其它

POJ - 3660 Cow Contest

2017-08-28 16:49 253 查看
[align=center]Cow Contest[/align]

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 12848Accepted: 7149
Description

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is
unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow
A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤
B ≤ N; A ≠ B), then cow A will always beat cow
B.

Farmer John is trying to rank the cows by skill level. Given a list the results of
M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and
M

* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer,
A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined

 

Sample Input
5 5
4 3
4 2
3 2
1 2
2 5

Sample Output
2

Source
USACO 2008 January Silver
[Submit]   [Go Back]   [Status]   [Discuss]

题意:
牛在比赛,问知道两头牛的关系。最终可以确定多少个牛的名次

思路:
只要找到某只牛与其他所有牛的关系则其名次一定可以确定

代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define INF 0x3f3f3f3f

int dis[105][105];
int n,m;

void floyd()
{
for(int k=1;k<=n;k++)
for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++)
//i 可直接或间接打败 j
if(dis[i][j] || (dis[i][k]&&dis[k][j]))
dis[i][j]=1;
}

int main()
{
scanf("%d%d",&n,&m);

memset(dis,0,sizeof(dis));
for(int i=0;i<m;i++)
{
int a,b;
scanf("%d%d",&a,&b);
dis[a][b]=1;//不能双向
}

floyd();

int sum=0;
for(int i=1;i<=n;i++)
{
int t=0;
for(int j=1;j<=n;j++)
{
if(dis[i][j] || dis[j][i])t++;
}
//只要确定了自己和其他所有的关系,则名次一定确定
if(t==n-1)sum++;
}
printf("%d\n",sum);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息