您的位置:首页 > 其它

HDU-1536-S-Nim && HDU-1944

2017-08-27 11:53 330 查看
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1536


S-Nim

Problem Description

Arthur and his sister Caroll have been playing a game called Nim for some time now. Nim is played as follows:

  The starting position has a number of heaps, all containing some, not necessarily equal, number of beads.

  The players take turns chosing a heap and removing a positive number of beads from it.

  The first player not able to make a move, loses.

Arthur and Caroll really enjoyed playing this simple game until they recently learned an easy way to always be able to find the best move:

  Xor the number of beads in the heaps in the current position (i.e. if we have 2, 4 and 7 the xor-sum will be 1 as 2 xor 4 xor 7 = 1).

  If the xor-sum is 0, too bad, you will lose.

  Otherwise, move such that the xor-sum becomes 0. This is always possible.

It is quite easy to convince oneself that this works. Consider these facts:

  The player that takes the last bead wins.

  After the winning player's last move the xor-sum will be 0.

  The xor-sum will change after every move.

Which means that if you make sure that the xor-sum always is 0 when you have made your move, your opponent will never be able to win, and, thus, you will win. 

Understandibly it is no fun to play a game when both players know how to play perfectly (ignorance is bliss). Fourtunately, Arthur and Caroll soon came up with a similar game, S-Nim, that seemed to solve this problem. Each player is now only allowed to remove
a number of beads in some predefined set S, e.g. if we have S =(2, 5) each player is only allowed to remove 2 or 5 beads. Now it is not always possible to make the xor-sum 0 and, thus, the strategy above is useless. Or is it? 

your job is to write a program that determines if a position of S-Nim is a losing or a winning position. A position is a winning position if there is at least one move to a losing position. A position is a losing position if there are no moves to a losing position.
This means, as expected, that a position with no legal moves is a losing position.

 

Input

Input consists of a number of test cases. For each test case: The first line contains a number k (0 < k ≤ 100 describing the size of S, followed by k numbers si (0 < si ≤ 10000) describing S. The second line contains a number m (0 < m ≤ 100) describing the
number of positions to evaluate. The next m lines each contain a number l (0 < l ≤ 100) describing the number of heaps and l numbers hi (0 ≤ hi ≤ 10000) describing the number of beads in the heaps. The last test case is followed by a 0 on a line of its own.

 

Output

For each position: If the described position is a winning position print a 'W'.If the described position is a losing position print an 'L'. Print a newline after each test case.

 

Sample Input

2 2 5
3
2 5 12
3 2 4 7
4 2 3 7 12
5 1 2 3 4 5
3
2 5 12
3 2 4 7
4 2 3 7 12
0

 

Sample Output

LWW
WWL

 

题目分析:

多组测试数据 ,输入 k表示集合的大小,输入可取的k个数据,m表示接下来对于这个集合要进行m次询问 m行每行输入一个n(n堆,每堆x个)。

这一行如果是赢输出W,否则输出L。

   

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;
int sg[10005],f[105];
bool math[10005];
int k,m,n,x;
void get_sg()//打表模板
{
int i,j;
memset(sg,0,sizeof(sg));
for(i=1; i<=10000; i++)
{
memset(math,0,sizeof(math));
for(j=1;j<=k&&f[j]<=i; j++)
math[sg[i-f[j]]] = 1;
for(j=0; j<=10000; j++)
{
if(math[j]==0)
{
sg[i]=j;
break;
}
}
}
}
int main()
{
int i;
while(~scanf("%d",&k))
{
if(k==0)
break;
string aa="";
for(i=1;i<=k;i++)
{
scanf("%d",&f[i]);
}
sort(f+1,f+k+1);
get_sg();
scanf("%d",&m);
while(m--)
{
int ans=0;
scanf("%d",&n);
for(i=1;i<=n;i++)
{
scanf("%d",&x);
ans^=sg[x];
}
if(ans)
aa+='W';
else
aa+='L';
}
//printf不能直接输出string类型,c_str()成员方法返回当前字符串的首字符地址
//printf("%s\n",aa.c_str());
cout<<aa<<endl;
}
return 0;
}

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
int sg[10005],f[105];
int k,m,n,a;
int get_sg(int x)
{
int i;
if(sg[x]!=-1)
return sg[x];
bool math[10005];//这个要放在里面!!!
memset(math,0,sizeof(math));
for(i=1;i<=k&&f[i]<=x;i++)
{
get_sg(x-f[i]);
math[sg[x-f[i]]]=1;
}
for(i=0;;i++)
{
if(math[i]==0)
{
sg[x]=i;
break;
}
}
return sg[x];
}
int main()
{
int i;
while(~scanf("%d",&k))
{
if(k==0)
break;
memset(sg,-1,sizeof(sg));
//sg[0]=0;
for(i=1;i<=k;i++)
{
scanf("%d",&f[i]);
}
sort(f+1,f+k+1);
scanf("%d",&m);
while(m--)
{
int ans=0;
scanf("%d",&n);
for(i=1;i<=n;i++)
{
scanf("%d",&a);
ans^=get_sg(a);
}
if(ans)
printf("W");
else
printf("L");
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: