您的位置:首页 > 编程语言

hdu3336—Count the string(kmp+dp)

2017-08-26 22:02 381 查看

Count the string

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11169 Accepted Submission(s): 5207


[align=left]Problem Description[/align] It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: “abab”
The prefixes are: “a”, “ab”, “aba”, “abab”
For each prefix, we can count the times it matches in s. So we can see that prefix “a” matches twice, “ab” matches twice too, “aba” matches once, and “abab” matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For “abab”, it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.

[align=left]Input[/align] The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.

[align=left]Output[/align] For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.
[align=left]Sample Input[/align]
1

4

abab

[align=left]Sample Output[/align]
6

[align=left]Author[/align] foreverlin@HNU
[align=left]Source[/align] HDOJ Monthly Contest – 2010.03.06
[align=left]Recommend[/align] lcy
Statistic | Submit | Discuss | Note

题意:求一个字符串所有前缀的数量和并mod10007

思路:利用Next数组:前i个字符所组成的字符串的最大前后缀匹配长度的性质,dp[i]=dp[Next[i-1]]+1,dp[i]是以i结尾的字符串数量,由Next可知此字符串也一定是前缀,+1即本身,所有前缀和等于所有的dp[i]相加,总之比较难理解。

#include<iostream>
#include<cstdio>
#include<cstring>
#define N 200005
using namespace std;
int Next
,dp
;//以i结尾的前缀总数
char s
;
void getnext(int n)
{
int i,j;
for(i=1,j=0; i<n; i++)
{
while(s[j]!=s[i]&&j>0)
j=Next[j-1];
if(s[i]==s[j])
j++;
Next[i]=j;
}
}
int main()
{
int t,n,i;
cin>>t;
while(t--)
{
cin>>n;
for(i=1; i<=n; i++)
dp[i]=0;
scanf("%s",s);
getnext(n);
int num=0;
for(i=1; i<=n; i++)
{
dp[i]=dp[Next[i-1]]+1;
num=(num+dp[i])%10007;
}
printf("%d\n",num);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  编程语言