您的位置:首页 > 其它

Zjnu Stadium(hdu-3047)(带权并查集)

2017-08-26 21:25 411 查看


Zjnu Stadium

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 4147    Accepted Submission(s): 1583


Problem Description

In 12th Zhejiang College Students Games 2007, there was a new stadium built in Zhejiang Normal University. It was a modern stadium which could hold thousands of people. The audience Seats made a circle. The total number of columns were 300 numbered 1--300,
counted clockwise, we assume the number of rows were infinite.

These days, Busoniya want to hold a large-scale theatrical performance in this stadium. There will be N people go there numbered 1--N. Busoniya has Reserved several seats. To make it funny, he makes M requests for these seats: A B X, which means people numbered
B must seat clockwise X distance from people numbered A. For example: A is in column 4th and X is 2, then B must in column 6th (6=4+2).

Now your task is to judge weather the request is correct or not. The rule of your judgement is easy: when a new request has conflicts against the foregoing ones then we define it as incorrect, otherwise it is correct. Please find out all the incorrect requests
and count them as R.

 

Input

There are many test cases:

For every case: 

The first line has two integer N(1<=N<=50,000), M(0<=M<=100,000),separated by a space.

Then M lines follow, each line has 3 integer A(1<=A<=N), B(1<=B<=N), X(0<=X<300) (A!=B), separated by a space

Sample Input

10 10
1 2 150
3 4 200
1 5 270
2 6 200
6 5 80
4 7 150
8 9 100
4 8 50
1 7 100
9 2 100

 

Sample Output

2

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#include<stack>
#include<string>
#include<map>
#include<vector>
#include<cmath>
#include<set>
#include<iostream>
using namespace std;
struct s{
int pre;
int val;
}a[100010];
int find_(int x)
{
if(x==a[x].pre)
{
return x;
}
int tmp=a[x].pre;
a[x].pre=find_(a[x].pre);
a[x].val+=a[tmp].val;
return a[x].pre;
}
int main()
{
int n,m;
while(scanf("%d%d",&n,&m)!=EOF)
{
for(int i=0;i<=n;i++)
{
a[i].pre=i;
a[i].val=0;
}
int ans=0;
for(int i=0;i<m;i++)
{
int x,y,z;
scanf("%d%d%d",&x,&y,&z);
int y1=find_(x);
int y2=find_(y);
if(y1!=y2)
{
a[y2].pre=y1;
a[y2].val=a[x].val+z-a[y].val;
}
else
{
if(a[x].val+z!=a[y].val)
{
ans++;
}
}
}
printf("%d\n",ans);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  带权并查集