您的位置:首页 > 其它

The kth great number(优先队列)

2017-08-25 23:36 375 查看


Problem G


Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65768/65768K (Java/Other)


Total Submission(s) : 47   Accepted Submission(s) : 17


Problem Description

Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help
Xiao Bao.

 

Input

There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao
Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number.

 

Output

The output consists of one integer representing the largest number of islands that all lie on one line.

 

Sample Input

8 3
I 1
I 2
I 3
Q
I 5
Q
I 4
Q

 

Sample Output

1
2
3

[hint]Xiao Ming won't ask Xiao Bao the kth great number when the number of the written number is smaller than k. (1=<k<=n<=1000000).[/hint]

 

题意:要求我们求出所给数列的第k大数。

思路:

一开始想的是用数状数组,但其实有更简单的方法,即运用STL中所学的优先队列。

代码:

#include <iostream>
#include <stdio.h>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
using namespace std;
struct node
{
int v;
friend bool operator<(node a,node b)
{
return a.v>b.v;
}
};
int main()
{
int n,k;
int l;
node s;
while(~scanf("%d%d",&n,&k))
{
priority_queue<node>q;

char p[2];
while(n--)
{
scanf("%s",p);
if(p[0]=='I')
{
scanf("%d",&l);
s.v=l;
q.push(s);
int t=q.size();
if(t>k)q.pop();
}
else
{ node ss=q.top();
printf("%d\n",ss.v);
}
}
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: