您的位置:首页 > 其它

zzuli2183: 就是签到题XD(欧拉常数)

2017-08-25 21:47 441 查看
传送门->点我
Description
In mathematics, we suppose that f(1)=1, f(i)-f(i-1)=1/i, (2<=i<=n)

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.Each case starts with a line containing an integer n (2 ≤ n ≤10^7).

Output

For each case, print the case number and the value of f(n). The answer should be rounded to 10 decimal places.

Sample Input

3234

Sample Output

Case 1: 1.5000000000Case 2: 1.8333333333Case 3: 2.0833333333题意:求f(n)=1/1+1/2+1/3+1/4…1/n,精确小数点后10位知识点:
     调和级数(即f(n))至今没有一个完全正确的公式,但欧拉给出过一个近似公式:(n很大时)
      f(n)≈ln(n)+C+1/2*n    
      欧拉常数值:C≈0.57721566490153286060651209
      c++ math库中,log即为ln。
但是n很小是直接求
贴代码:

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
#define inf 0x3f3f3f3f
#define maxn 10000011
double r = 0.57721566490153286060651209;
double a[10005];
int main()
{
a[1] = 1;
for(int i=2; i<=10000; i++)
a[i] = a[i-1] + 1.0/i;
int t;
scanf("%d",&t);
for (int cas=1; cas<=t; cas++)
{
int n;
scanf("%d",&n);
if(n <= 10000)
printf("Case %d: %.10lf\n",cas,a
);
else
{
double sum;
sum = log(n) + r + 1.0/(2*n);
printf("Case %d: %.10lf\n",cas,sum);
}
}
}



内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: