您的位置:首页 > 产品设计 > UI/UE

1041. Be Unique (20) Hash散列

2017-08-25 21:22 295 查看
Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1, 104]. The first one who bets on a unique number wins. For
example, if there are 7 people betting on 5 31 5 88 67 88 17, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (<=105) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print "None" instead.
Sample Input 1:
7 5 31 5 88 67 88 17

Sample Output 1:
31

Sample Input 2:
5 888 666 666 888 888

Sample Output 2:
None


题意:

给定一个数N 和N个数,要求求出这N个数中第一个独一无二的数(即与其他N-1个数是不相同的)

分析:建立一个数组,存储每个数字出现的次数,然后遍历一遍输入的顺序看是否有出现次数为1的数字

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <vector>
#include <set>
using namespace std;
const int maxn = 1e5+10;
int a[maxn],m[maxn];
int main()
{
int n;
cin >> n;
for(int i = 0;i < n;i++)
{
scanf("%d",&a[i]);
m[a[i]]++;
}
for(int i = 0;i < n;i++)
{
if(m[a[i]] == 1)
{
printf("%d",a[i]);
return 0;
}
}
printf("None");
return 0;
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: