您的位置:首页 > 其它

Tian Ji -- The Horse Racing **

2017-08-25 08:52 267 查看
Here is a famous story in Chinese history.
That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others.

Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from
the loser.

Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian.

Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match.

It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you think
of Tian Ji, the high ranked official in China?



Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's
horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find
the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses -- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too
advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.
Input
The input consists of up to 50 test cases. Each case starts with a positive integer n ( n<=1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian's horses.
Then the next n integers on the third line are the speeds of the king's horses. The input ends with a line that has a single `0' after the last test case.
Output
For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.
Sample Input
3
92 83 71
95 87 74
2
20 20
20 20
2
20 19
22 18
0

Sample Output
200
0
0

用到贪心,感觉还是理解的比较模糊。之后再来看看。

就像是博弈,我们总是想用最少的损失来换取对方最大的损失。

所以我们进行贪心。

1.如果tian最快的马比king 最快的马 快的话,直接比之;

2.如果tian 最快的马比king最快的马慢的话,我们就用tian最慢的马,这样tian的损失最小,king 的损失最大。

3.如果想等的话,我们不应该直接比之:

    (1)如果tian最慢的马比king最慢的马快的话,直接比较,然后看倒数第二头。就是能赢一局就一局的感觉

    (2)如果说tian最慢的马与king的慢马相等,甚至比king的慢马 慢的话,我们就用tian的慢马比较king最快的马,这样tian的慢马发挥的效用最大。
#include <iostream>
#include<stdio.h>
#include<algorithm>
using namespace std;

int tian_sp[1010];
int king_sp[1010];

int cmp(int a,int b)
{
return a>b;
}

int main()
{
int n;
while(~scanf("%d",&n)&&n)
{
for(int i=0;i<n;i++)
scanf("%d",&tian_sp[i]);
for(int i=0;i<n;i++)
scanf("%d",&king_sp[i]);
sort(tian_sp,tian_sp+n,cmp);
sort(king_sp,king_sp+n,cmp);
int fr_tian,fr_king ,sum;
fr_tian=fr_king=0;
sum=0;
int tail_tian=n-1;int tail_king=n-1;
int round=0;
while(1)
{
if(round==n)
break;
if(tian_sp[fr_tian]>king_sp[fr_king])
{
sum+=200;
fr_tian++;
fr_king++;
}
else if(tian_sp[fr_tian]<king_sp[fr_king])
{
sum-=200;
fr_king++;
tail_tian--;
}
else if(tian_sp[fr_tian]==king_sp[fr_king])
{
if(tian_sp[tail_tian]>king_sp[tail_king])
{
sum += 200;
tail_king--;
tail_tian--;
}
else if(tian_sp[tail_tian]<king_sp[fr_king])
{
sum-=200;
tail_tian--;
fr_king++;
}
else
{
tail_tian--;
fr_king++;
}
}
round++;
}
printf("%d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  贪心