您的位置:首页 > 其它

HDU 6181 Two Paths【次短路】【模板题】

2017-08-24 22:00 489 查看


Two Paths

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 153428/153428 K (Java/Others)

Total Submission(s): 236    Accepted Submission(s): 138


Problem Description

You are given a undirected graph with n nodes (numbered from 1 to n) and m edges. Alice and Bob are now trying to play a game. 

Both of them will take different route from 1 to n (not necessary simple).

Alice always moves first and she is so clever that take one of the shortest path from 1 to n.

Now is the Bob's turn. Help Bob to take possible shortest route from 1 to n.

There's neither multiple edges nor self-loops.

Two paths S and T are considered different if and only if there is an integer i, so that the i-th edge of S is not the same as the i-th edge of T or one of them doesn't exist.

 

Input

The first line of input contains an integer T(1 <= T <= 15), the number of test cases.

The first line of each test case contains 2 integers n, m (2 <= n, m <= 100000), number of nodes and number of edges. Each of the next m lines contains 3 integers a, b, w (1 <= a, b <= n, 1 <= w <= 1000000000), this means that there's an edge between node a
and node b and its length is w.

It is guaranteed that there is at least one path from 1 to n.

Sum of n over all test cases is less than 250000 and sum of m over all test cases is less than 350000.

 

Output

For each test case print length of valid shortest path in one line.

 

Sample Input

2
3 3
1 2 1
2 3 4
1 3 3
2 1
1 2 1

 

Sample Output

5
3
Hint
For testcase 1, Alice take path 1 - 3 and its length is 3, and then Bob will take path 1 - 2 - 3 and its length is 5.
For testcase 2, Bob will take route 1 - 2 - 1 - 2 and its length is 3

 

Source

2017 Multi-University Training Contest - Team 10

套一个次短路模板即可

#include <bits/stdc++.h>
#define INF 1e16+100
#define ms(x,y) memset(x,y,sizeof(x))
using namespace std;

typedef long long ll;
typedef pair<ll,ll> P;

const double pi = acos(-1.0);
const int mod = 1e9 + 7;
const int maxn = 1e5 + 5;

struct Edge{
ll to,cost;
};

ll n,m;
vector<Edge> a[maxn];
ll dist[maxn],dist2[maxn];

void addedge(ll u,ll v,ll w)
{
a[u].push_back(Edge{v,w});
a[v].push_back(Edge{u,w});
}

void solve()
{
priority_queue<P, vector<P>, greater<P> >que;
//ms(dist,INF);
//ms(dist2,INF);
fill(dist,dist+n,INF);
fill(dist2,dist2+n,INF);
dist[0]=0;
que.push(P(0,0));
while(que.size())
{
P u=que.top();que.pop();
int v=u.second;
ll d=u.first;
if(dist2[v]<d) continue; //不是次短距离则抛弃
for(int i=0;i<a[v].size();i++)
{
Edge e=a[v][i];
ll d2=d+e.cost;
if(dist[e.to]>d2) //更新最短
{
swap(dist[e.to],d2);
que.push(P(dist[e.to],e.to));
}
if(dist2[e.to]>d2&&dist[e.to]<d2) //更新次短
{
dist2[e.to]=d2;
que.push(P(dist2[e.to],e.to));
}
}
}
printf("%lld\n",dist2[n-1]);
}

int main()
{
//freopen("in.txt","r",stdin);
//freopen("out.txt","w",stdout);
int t;
scanf("%d",&t);
while(t--)
{
scanf("%lld%lld",&n,&m);
for(int i=0;i<n;i++) a[i].clear();
for(int i=0;i<m;i++)
{
ll p,q,w;
scanf("%lld%lld%lld",&p,&q,&w);
addedge(p-1,q-1,w);
}
solve();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: