您的位置:首页 > 其它

POJ 1201 Intervals(差分约束系统)

2017-08-24 20:08 417 查看
Intervals

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 27491 Accepted: 10583
Description

You are given n closed, integer intervals [ai, bi] and n integers c1, ..., cn. 

Write a program that: 

reads the number of intervals, their end points and integers c1, ..., cn from the standard input, 

computes the minimal size of a set Z of integers which has at least ci common elements with interval [ai, bi], for each i=1,2,...,n, 

writes the answer to the standard output. 

Input

The first line of the input contains an integer n (1 <= n <= 50000) -- the number of intervals. The following n lines describe the intervals. The (i+1)-th line of the input contains three integers ai, bi and ci separated by single spaces and such that 0 <=
ai <= bi <= 50000 and 1 <= ci <= bi - ai+1.
Output

The output contains exactly one integer equal to the minimal size of set Z sharing at least ci elements with interval [ai, bi], for each i=1,2,...,n.
Sample Input
5
3 7 3
8 10 3
6 8 1
1 3 1
10 11 1

Sample Output
6

Source

Southwestern Europe 2002

题意:有n个区间[ai,bi],找一最短序列,要求该序列中至少有ci个数字在区间[ai,bi]上。

差分约束系统要求最小值,求出最长路径即可。根据题目给出的条件bi-ai+1>=ci,构造出来的边显然不足以求出最长路径,因为有很多点依然没有连接起来,导致可能不存在从起点到终点的路线。因此,寻找隐藏边,最大区间的点应该满足0<=点<=1。加上这个隐藏边,显然可以求出最长路径了。

代码:

#include <iostream>
#include <stack>
#include <algorithm>
#include <string.h>
using namespace std;

const int MAXN = 50005;
const int MAXE = 150005;

typedef struct Edge
{
int v, w;
int next;
}Edge;

Edge edge[MAXE];
int dist[MAXN], head[MAXN];
bool used[MAXN];
int cnt=0, n, m;
int Min,Max;

void add_edge(int u, int v, int w)
{
edge[cnt].v = v;
edge[cnt].w = w;
edge[cnt].next = head[u];
head[u] = cnt++;
}

void spfa()
{
int sta[MAXN];
memset(used, false, sizeof(used));
for(int i=Min;i<=Max;i++)
dist[i] = -0x3f3f3f3f;
int top=0;
sta[++top] = Min;//进栈
dist[Min] = 0;
used[Min] = true;//标记
while (top)
{
int u = sta[top--];//出栈
used[u] = false;//去除标记
for (int i=head[u]; i!=-1; i=edge[i].next)
{
int v = edge[i].v;
int w = edge[i].w;
if (dist[v]<dist[u]+w)
{
dist[v] = dist[u] + w;
if (!used[v])
{
used[v] = true;
sta[++top] = v;
}
}
}
}
}

int main()
{
while(~scanf("%d", &n))
{
memset(head,-1,sizeof(head));
int u,v,w;
Max=-0x3f3f3f3f,Min=0x3f3f3f3f;
for(int i=0;i<n;i++)
{
scanf("%d%d%d", &u,&v,&w);//题目条件的边
add_edge(u,v+1,w);
Min = min(Min, u);//在这里记录最小值和最大值,所求的就是以Min为源点
Max = max(Max, v+1);//以Max为终点的最短路
}
for(int i = Min;i < Max; i++)//添加新边
{
add_edge(i,i+1,0);
add_edge(i+1,i,-1);
}
spfa();
printf("%d\n", dist[Max]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: