您的位置:首页 > 其它

POJ 2955 _Brackets (区间Dp)

2017-08-24 10:53 316 查看
传送门:http://poj.org/problem?id=2955

Brackets

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8881 Accepted: 4763
Description

We give the following inductive definition of a “regular brackets” sequence:

the empty sequence is a regular brackets sequence,
if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
if a and b are regular brackets sequences, then ab is a regular brackets sequence.
no other sequence is a regular brackets sequence
For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]


while the following character sequences are not:

(, ], )(, ([)], ([(]


Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such
that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im ≤ n, ai1ai2 … aim is
a regular brackets sequence.

Given the initial sequence 
([([]])]
, the longest regular brackets subsequence is 
[([])]
.

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters 
(
)
[
, and 
]
; each input test will have length between 1 and 100, inclusive.
The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input
((()))
()()()
([]])
)[)(
([][][)
end

Sample Output
6
6
4
0
6

题目大意:
括号匹配只有( ) [ ]这四个括号,问能够匹配成功的最大长度是多少。

题解:

因为这个题是在区间dp专题里找的,所以直接往这上面想还是比较好想的。定义dp[i][j]表示区间[i,j]内的最大长度。如果s[i]匹配s[j]的话dp[i][j]=dp[i+1][j-1]+2.不然就取k,i<=k<=j使得dp[i][j]=max(dp[i][k],dp[k+1][j])初始条件都是0就可以了。区间dp的套路(个人感觉)先枚举长度确定i,j,在用k更新。这样也可以避免后效性吧。

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <algorithm>
#include <map>
using namespace std;

char s[120];
int dp[120][120];
int main(){
while(~scanf("%s",s+1)){
if(strcmp(s+1,"end")==0)break;
int len = strlen(s+1);
memset(dp,0,sizeof(dp));
for(int p = 1;p<len;p++)
for(int i=1;i<=len-p;i++){
int j = i+p;
if((s[i]=='('&&s[j]==')')||(s[i]=='['&&s[j]==']'))dp[i][j]=dp[i+1][j-1]+2;
for(int k = i;k<j;k++)dp[i][j]=max(dp[i][j],dp[i][k]+dp[k+1][j]);
}
printf("%d\n",dp[1][len]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: