您的位置:首页 > 其它

【HDU 1051】Wooden Sticks(贪心)

2017-08-24 10:27 387 查看

Wooden Sticks

Description

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:

(a) The setup time for the first wooden stick is 1 minute.

(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l’ and weight w’ if l<=l’ and w<=w’. Otherwise, it will need 1 minute for setup.

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, …, ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

Output

The output should contain the minimum setup time in minutes, one per line.

Sample Input

3

5

4 9 5 2 2 1 3 5 1 4

3

2 2 1 1 2 2

3

1 3 2 2 3 1

Sample Output

2

1

3

题意:

改造木棍。有如下要求:

1. 第一根必定会花费1分钟。

2. 如果接下来的一根比前一根的 长度和重量 全都小,则不需要花时间。若有一个比较大,则需要花费1分钟。

木棍可以排序,求出改造完成所需要的最短时间。

思路:

可以先将木棍按照长度(主要)和重量(次要)排序(这里是从小到大,从大到小也可以)。如果长度相等,则重量从小到大

给木棍设置一个vis变量标记是否之前已经访问过,初始时全置为false。排序之后,从第一个木棍开始为初始木棍,将之后的木棍全遍历一遍,如果没有访问过而且质量比之前的大,则vis置为访问过true并改变weight。之后依次寻找木棍,若没有访问过,ans++,并再次对其进行上述过程(遍历之后的木棍)。

代码:

#include<iostream>
#include<algorithm>
#define MAX 5000+5
using namespace std;
struct stick{
int length;
int weight;
bool vis;
}s[MAX];

bool cmp(struct stick a,struct stick b)
{
if(a.length==b.length) return a.weight<b.weight;
else return a.length<b.length;
}

int main()
{
int t,n;
cin>>t;
while(t--)
{
cin>>n;
for(int i=0;i<n;i++)
{
cin>>s[i].length>>s[i].weight;
s[i].vis=false;
}
sort(s,s+n,cmp);
int ans=0;
for(int i=0;i<n;i++)
{
if(!s[i].vis)
{
s[i].vis=true;
ans++;
int weight=s[i].weight;
for(int j=i+1;j<n;j++)
{
if(!s[j].vis&&s[j].weight>=weight)
{
s[j].vis=true;
weight=s[j].weight;
}
}
}
}
cout<<ans<<endl;
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  HDU-1051 贪心算法