您的位置:首页 > 其它

FZU 2271:Problem 2271 X <Floyd>

2017-08-24 10:11 344 查看

Problem 2271 X

Accept: 210    Submit: 783

Time Limit: 1500 mSec    Memory Limit : 32768 KB



Problem Description

X is a fully prosperous country, especially known for its complicated transportation networks. But recently, for the sake of better controlling by the government, the president Fat Brother thinks it’s time to close some roads in order to make the transportation
system more effective.

Country X has N cities, the cities are connected by some undirected roads and it’s possible to travel from one city to any other city by these roads. Now the president Fat Brother wants to know that how many roads can be closed at most such that the distance
between any two cities in country X does not change. Note that the distance between city A and city B is the minimum total length of the roads you need to travel from A to B.



Input

The first line of the date is an integer T (1 <= T <= 50), which is the number of the text cases.

Then T cases follow, each case starts with two numbers N, M (1 <= N <= 100, 1 <= M <= 40000) which describe the number of the cities and the number of the roads in country X. Each case goes with M lines, each line consists of three integers x, y, s (1 <=
x, y <= N, 1 <= s <= 10, x is not equal to y), which means that there is a road between city x and city y and the length of it is s. Note that there may be more than one roads between two cities.



Output

For each case, output the case number first, then output the number of the roads that could be closed. This number should be as large as possible.

See the sample input and output for more details.



Sample Input

22 31 2 11 2 11 2 23 31 2 12 3 11 3 1



Sample Output

Case 1: 2Case 2: 0



Source

第七届福建省大学生程序设计竞赛-重现赛(感谢承办方闽江学院)

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cctype>
#include <algorithm>
#define maxn 111111
#define LL long long
#define inf 0x3f3f3f
#define INF 1e5
using namespace std;
int n,m;
int d[105][105];
int maps[105][105];
void floyd()
{
for(int k=1; k<=n; k++)
for(int i=1; i<=n; i++)
for(int j=1; j<=n; j++)
if(d[i][j]>d[i][k]+d[k][j])
d[i][j]=d[i][k]+d[k][j];
}
int main()
{
int t;
scanf("%d",&t);

int cas=1;
while(t--)
{

int ans=0;
scanf("%d %d",&n,&m);
for(int i=1; i<=n; i++)
for(int j=1; j<=n; j++)
if(i!=j)
{

maps[i][j]=INF;
}
else
{

maps[i][j]=0;
}
int x,y,c;
for(int i=0; i<m; i++)
{
scanf("%d %d %d",&x,&y,&c);
if(maps[x][y]!=INF)
ans++;
if(maps[x][y]>c)
{
maps[x][y]=maps[y][x]=c;

}
}

memcpy(d,maps,sizeof(d));
floyd();

for(int i=1; i<=n; i++)
for(int j=i+1; j<=n; j++)
for(int k=1; k<=n; k++)
{
if(d[i][j]<maps[i][j]&&maps[i][j]!=INF&&j!=k&&i!=k)
{
ans++;
break;
}
if(d[i][j]==d[i][k]+d[k][j]&&maps[i][j]!=INF&&k!=i&&k!=j)
{
ans++;
break;
}
}

printf("Case %d: %d\n",cas++,ans);

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM OJ fzu