您的位置:首页 > 其它

HDOJ1240 BFS入门水题 + BFS模板程序

2017-08-23 21:16 267 查看


Asteroids!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 5551    Accepted Submission(s): 3531


Problem Description

You're in space.

You want to get home.

There are asteroids.

You don't want to hit them.

 

Input

Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets.

A single data set has 5 components:

Start line - A single line, "START N", where 1 <= N <= 10.

Slice list - A series of N slices. Each slice is an N x N matrix representing a horizontal slice through the asteroid field. Each position in the matrix will be one of two values:

'O' - (the letter "oh") Empty space

'X' - (upper-case) Asteroid present

Starting Position - A single line, "A B C", denoting the <A,B,C> coordinates of your craft's starting position. The coordinate values will be integers separated by individual spaces.

Target Position - A single line, "D E F", denoting the <D,E,F> coordinates of your target's position. The coordinate values will be integers separated by individual spaces.

End line - A single line, "END"

The origin of the coordinate system is <0,0,0>. Therefore, each component of each coordinate vector will be an integer between 0 and N-1, inclusive.

The first coordinate in a set indicates the column. Left column = 0.

The second coordinate in a set indicates the row. Top row = 0.

The third coordinate in a set indicates the slice. First slice = 0.

Both the Starting Position and the Target Position will be in empty space.

 

Output

For each data set, there will be exactly one output set, and there will be no blank lines separating output sets.

A single output set consists of a single line. If a route exists, the line will be in the format "X Y", where X is the same as N from the corresponding input data set and Y is the least number of moves necessary to get your ship from the starting position to
the target position. If there is no route from the starting position to the target position, the line will be "NO ROUTE" instead.

A move can only be in one of the six basic directions: up, down, left, right, forward, back. Phrased more precisely, a move will either increment or decrement a single component of your current position vector by 1.

 

Sample Input

START 1
O
0 0 0
0 0 0
END
START 3
XXX
XXX
XXX
OOO
OOO
OOO
XXX
XXX
XXX
0 0 1
2 2 1
END
START 5
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
XXXXX
XXXXX
XXXXX
XXXXX
XXXXX
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
0 0 0
4 4 4
END

 

Sample Output

1 0
3 4
NO ROUTE

 

Source

South Central USA 2001

 

Recommend

zf   |   We have carefully selected several similar problems for you:  1238 1239 1254 1401 1195 

给你一个三维迷宫,问从起点到终点的最短步数,‘X’表示不能通过。

#include <iostream>
#include <ctime>
#include <cstring>
#include <queue>
using namespace std;

const int maxn =12;
string str;
int i,j,k,n;
int sx,sy,sz,ex,ey,ez;
int dx[]={1,-1,0,0,0,0};
int dy[]={0,0,1,-1,0,0};
int dz[]={0,0,0,0,1,-1};
char MAP[maxn][maxn][maxn];
struct node{
int x,y,z,step;
}p,q;
queue<node>a;

void init(){
for (k=0; k<n; k++)
for (i=0; i<n; i++)
for (j=0; j<n; j++)
cin >> MAP[k][i][j];
cin >> sx >> sy >> sz;
cin >> ex >> ey >> ez;
cin >> str;
while (!a.empty()) a.pop();
p.x = sx; p.y = sy; p.z = sz; p.step = 0;
a.push(p);
MAP[ex][ey][ez]='O';
}

bool check(node f){
if (f.x<0 || f.y<0 || f.z<0 || f.x>=n || f.y>=n || f.z>=n) return 0;
if (MAP[f.x][f.y][f.z]=='X') return 0;
return 1;
}

bool bfs(){
while (!a.empty()) {
p = a.front();
a.pop();
if (p.x==ex && p.y==ey && p.z==ez) {
cout << n << " " << p.step << endl;
return 1;
}
for (i=0; i<6; i++) {
q = p;
q.x+=dx[i];
q.y+=dy[i];
q.z+=dz[i];
q.step++;
if (!check(q)) continue;
MAP[q.x][q.y][q.z] = 'X';
a.push(q);
}
}
return 0;
}

int main(){
std::ios::sync_with_stdio(false);
while (cin >>str >> n){
init();
if (!bfs()) cout << "NO ROUTE" << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: