您的位置:首页 > 其它

1002. A+B for Polynomials (25)

2017-08-23 15:33 429 查看

题目:

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 … NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < … < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input

2 1 2.4 0 3.2

2 2 1.5 1 0.5

Sample Output

3 2 1.5 1 2.9 0 3.2

解答:

//给出两个多项式,计算他们的和
#include<cstdio>
int main(){
double ans[1001]={0};//用来存储和,索引值为幂数,值为总系数
int a,b,temp;//两个多项式的系数以及临时幂数
double c;
scanf("%d",&a);
for(int i=0;i<a;i++){
scanf("%d%lf",&temp,&c);//输入各项幂数以及对应的系数
ans[temp]=c;
}
scanf("%d",&b);
for(int i=0;i<b;i++){
scanf("%d%lf",&temp,&c);//输入各项幂数以及对应的系数
ans[temp]+=c;
}
int ans1=0;
for(int i=0;i<1001;i++){
if(ans[i]!=0)ans1++;
}
printf("%d",ans1);
for(int i=1000;i>=0;i--){
if(ans[i]!=0)printf(" %d %.1f",i,ans[i]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: