您的位置:首页 > 其它

HDU 6033 Add More Zero(取对数求一个数长度)

2017-08-23 15:03 302 查看


Add More Zero

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 1687    Accepted Submission(s): 1072


Problem Description

There is a youngster known for amateur propositions concerning several mathematical hard problems.

Nowadays, he is preparing a thought-provoking problem on a specific type of supercomputer which has ability to support calculations of integers between 0 and (2m−1) (inclusive).

As a young man born with ten fingers, he loves the powers of 10 so
much, which results in his eccentricity that he always ranges integers he would like to use from 1 to 10k (inclusive).

For the sake of processing, all integers he would use possibly in this interesting problem ought to be as computable as this supercomputer could.

Given the positive integer m,
your task is to determine maximum possible integer k that
is suitable for the specific supercomputer.

 

Input

The input contains multiple test cases. Each test case in one line contains only one positive integer m,
satisfying 1≤m≤105.

 

Output

For each test case, output "Case #x: y"
in one line (without quotes), where x indicates
the case number starting from 1 and y denotes
the answer of corresponding case.

 

Sample Input

1
64

 

Sample Output

Case #1: 0
Case #2: 19

 
题意:求2的m次方的长度
思路:利用log10可以知道一个数有几位的性质,再用对数的运算法则可以求任意数的长度
#include <iostream>
#include <cstdio>
#include <cstring>
#include <stdio.h>
#include <stdlib.h>
#include <algorithm>
#include <math.h>
using namespace std;
int main()
{
int n,cas=1;
while(scanf("%d",&n)!=EOF)
{
printf("Case #%d: ",cas++);
int len=n*log10(2);
printf("%d\n",len);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: