您的位置:首页 > 其它

Flip Game POJ - 1753 bfs

2017-08-23 11:43 393 查看
Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each
round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules:
Choose any one of the 16 pieces.

Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).


Consider the following position as an example:

bwbw

wwww

bbwb

bwwb

Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become:

bwbw

bwww

wwwb

wwwb

The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal.

Input
The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.
Output
Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the
goal, then write the word "Impossible" (without quotes).
Sample Input
bwwb
bbwb
bwwb
bwww

Sample Output
4


 

题意 b为黑色,w为白色 翻转一个棋子,会影响四周也翻转,求最少翻转次数,使全部都是白,或全部都是黑 若不可能则输出impossible

思路: 为4*4方格 可以枚举每一种状态为2^16-1;利用二进制表示  0为白色,1为黑色,

     翻转棋盘可以利用位或,相同为0,不同为1,从而达到翻转的目的,用count记录翻转的次数

#include<iostream>
#include<cstring>
#include<queue>
using namespace std;
const int M=65535;
struct  node
{
int count;
int vis;
};
node no[M+1];
queue<int>que;
bool check(int i,int j)
{
if(i<0||i>=4)
return false;
if(j<0||j>=4)
return false;
return true;
}
int main()
{
cha
4000
r c;
int id=0;
for(int i=0;i<=M;i++)
{
no[i].count=0;
no[i].vis=0;
}
for(int i=0;i<16;i++)//计算出b的位置
{
cin>>c;
id<<=1;
if(c=='b')
id|=1;
}
if(id==0||id==M)
{
cout<<"0"<<endl;
return 0;
}
que.push(id);
no[id].vis=1;
int temp,pos,t;
while(que.size())
{
temp=que.front();
que.pop();
for(int i=0;i<4;i++)
for(int j=0;j<4;j++)
{
t=temp,pos=4*i+j;
t^=1<<(15-pos);
//判断四个方向是否可以翻转,可以则进行翻转
if(check(i-1,j))
t^=1<<(19-pos);
if(check(i,j-1))
t^=1<<(16-pos);
if(check(i,j+1))
t^=1<<(14-pos);
if(check(i+1,j))
t^=1<<(11-pos);
no[t].count=no[temp].count+1;
if(t==0||t==M)
{
cout<<no[t].count<<endl;
return 0;
}
if(!no[t].vis)
{
no[t].vis=1;
que.push(t);
}
}
}
cout<<"Impossible"<<endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: