您的位置:首页 > 其它

POJ3259--Wormholes(SPFA)

2017-08-23 10:38 295 查看
Do more with less

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ’s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.

Line 1 of each farm: Three space-separated integers respectively: N, M, and W

Lines 2..M+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.

Lines M+2..M+W+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1..F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes).

Sample Input

2

3 3 1

1 2 2

1 3 4

2 3 1

3 1 3

3 2 1

1 2 3

2 3 4

3 1 8

Sample Output

NO

YES

Hint

For farm 1, FJ cannot travel back in time.

For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

思路

用SPFA来判断负环

关于SPFA,是BF算法的队列优化,优化的方式是每次进行“松弛”操作的边,是经过改变的边,这样避免了很多的无用操作

关于松弛操作,和dijkstra算法一样。

代码

#include <iostream>
#include <cstring>
#include <vector>
#include <queue>
using namespace std;
const int N = 505;
const int INF = 1 << 25;
int  map

;
int n , m , t;
void SPFA()
{
int dis
; int cnt
; bool vis
;
//dis表示源点到各点的最短路 cnt表示松弛的次数 vis表示是否加入过队列
queue<int > q;
memset(vis,false,sizeof(vis));
memset(cnt,0,sizeof(cnt));
for(int i = 0; i < N; i ++)
dis[i] = INF;
dis[1] = 0; cnt[1] ++; vis[1] = true; q.push(1);
while( !q.empty() )
{
int top = q.front(); q.pop(); vis[top] = false;
for(int i = 1; i <= n; i ++)
{
int e = i;
if(dis[top] < INF && dis[e] > dis[top] + map[top][i])
{
dis[e] = dis[top] + map[top][i]; //“松弛”操作
if( !vis[e] )
{
vis[e] = true; cnt[e]++;
if( cnt[e]>=n )
{
cout << "YES" << endl;//有负环
return ;
}
q.push(e);
}
}
}
}
cout << "NO" << endl;

}
int main()
{
int T;
cin >> T;
while(T--)
{
cin >> n >> m >> t;
for(int i = 0; i <= n; i ++)
for(int j = 0; j <= n; j ++)
if(i == j)
map[i][j] = 0;
else
map[j][i] = map[i][j] = INF;
for(int i = 0; i < m; i ++)
{
int s, e, w;
cin >> s >> e >> w;
map[s][e] = min(map[s][e],w);
map[e][s] = min(map[e][s],w);
}
for(int i = 0; i < t; i ++)
{
int s, e, w;
cin >> s >> e >> w;
map[s][e] = min(map[s][e],-w);
}
SPFA();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: