您的位置:首页 > 其它

hdu 6168 Numbers【map】

2017-08-23 09:14 399 查看


Numbers

Problem Description

zk has n numbers a1,a2,...,an.
For each (i,j) satisfying 1≤i<j≤n, zk generates a new number (ai+aj).
These new numbers could make up a new sequence b1,b2,...,bn(n−1)/2.

LsF wants to make some trouble. While zk is sleeping, Lsf mixed up sequence a and b with random order so that zk can't figure out which numbers were in a or b. "I'm angry!", says zk.

Can you help zk find out which n numbers were originally in a?

 

Input

Multiple test cases(not exceed 10).

For each test case:
∙The
first line is an integer m(0≤m≤125250), indicating the total length of a and b. It's guaranteed m can be formed as n(n+1)/2.
∙The
second line contains m numbers, indicating the mixed sequence of a and b.

Each ai is
in [1,10^9]

 

Output

For each test case, output two lines.

The first line is an integer n, indicating the length of sequence a;

The second line should contain n space-seprated integers a1,a2,...,an(a1≤a2≤...≤an).
These are numbers in sequence a.

It's guaranteed that there is only one solution for each case.

 

Sample Input

6
2 2 2 4 4 4
21
1 2 3 3 4 4 5 5 5 6 6 6 7 7 7 8 8 9 9 10 11

 

Sample Output

3
2 2 2
6
1 2 3 4 5 6

 

Source

2017 Multi-University Training Contest - Team 9

 
思路:

先取出两个最小的,然后组合成X,把X删去,再取,删去的这个过程放到map里就好了。

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <map>
#include <string>
#define max_n 125300
typedef long long LL;
using namespace std;
int a[max_n], b[max_n];
map<int, int> ma;

int main() {
int n;
while(~scanf("%d", &n)) {
int p = 1;
ma.clear();
for(int i = 0; i < n; i++) {
scanf("%d", &a[i]);
ma[a[i]]++;
}
b[0] = a[0];
for(int i = 1; i < n; i++) {
if(p > 600) break;
if(!ma[a[i]]) continue;
ma[a[i]]--;
for(int j = 0; j < p; j++) {
ma[a[i] + b[j]]--;
}
b[p++] = a[i];
}
printf("%d\n", p);
for(int i = 0; i < p; i++) {
if(i > 0) printf(" ");
printf("%d", b[i]);
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: