您的位置:首页 > 其它

1002. A+B for Polynomials (25)

2017-08-22 21:00 477 查看
memset的头文件是<string.h>

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where
K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output
3 2 1.5 1 2.9 0 3.2

#include<iostream>
#include<string.h>
#include<iomanip>
using namespace std;
int main()
{
int k1, k2, n;
float arry[1001], an;
memset(arry, 0, sizeof(arry));
cin >> k1;
int count = 0, maxn = 0;
for (int i = 0; i < k1; i++)
{
cin >> n >> an;
maxn = maxn > n ? maxn : n;
arry
= an;
}
cin >> k2;
for (int i = 0; i < k2; i++)
{
cin >> n >> an;
maxn = maxn > n ? maxn : n;
arry
+= an;
}
for (int i = maxn; i >= 0; i--)
if (arry[i] != 0) count++;
cout << count;
for (int i = maxn; i >= 0; i--)
{
if (arry[i] != 0)
cout << " " << i << " " << setiosflags(ios::fixed) << setprecision(1) << arry[i];
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: