您的位置:首页 > 其它

hdu 6168 Numbers (STL)

2017-08-22 20:20 369 查看
Numbers

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 211 Accepted Submission(s): 112

Problem Description

zk has n numbers a1,a2,…,an. For each (i,j) satisfying j>i, zk generates a new number (ai+aj). These new numbers could make up a new sequence b1,b2,…,bn(n−1)/2.

LsF wants to make some trouble. While zk is sleeping, Lsf mixed up sequence a and b with random order so that zk can’t figure out which numbers were in a or b. “I’m angry!”, says zk.

Can you help zk find out which n numbers were originally in a?

Input

Multiple test cases(not exceed 10).

For each test case:



The first line is an integer m(0≤m≤125250), indicating the total length of a and b. It’s guaranteed m can be formed as n(n+1)/2.



The second line contains m numbers, indicating the mixed sequence of a and b.

Each

a

i

is in [1,10^9]

Output

For each test case, output two lines.

The first line is an integer n, indicating the length of sequence a;

The second line should contain n space-seprated integers

a1,a2,…,an(a1,a2≤…≤an). These are numbers in sequence a.

It’s guaranteed that there is only one solution for each case.

Sample Input

6

2 2 2 4 4 4

21

1 2 3 3 4 4 5 5 5 6 6 6 7 7 7 8 8 9 9 10 11

Sample Output

3

2 2 2

6

1 2 3 4 5 6

题意:

a,b数组打乱后放在一起,b数组的每一个元素都是由a中任意两个元素相加得到的且b有(n-1)*n/2个,a有n个

解析:

一开始最小的两个一定是a[0],a[1],这样之后就可以求出b,再这样一步步递推下去就行了

#include<cstdio>
#include<cstring>
#include<queue>
#include<vector>
#include<map>
using namespace std;
#define MAXN 130000

struct cmp
{
bool operator()(int &a,int &b)
{
return a>b;
}
};

priority_queue<int,vector<int>,cmp> que1;
int a[MAXN];
map<long long int,int> b;

int main()
{
int n,c;
while(scanf("%d",&n)!=EOF)
{
while(que1.size()) que1.pop();
b.clear();
for(int i=0;i<n;i++)
{
scanf("%d",&c);
que1.push(c);
}
a[0]=que1.top();
que1.pop();
a[1]=que1.top();
que1.pop();
b[a[0]+a[1]]++;
int k=2;
int len=(sqrt(1+8*n)-1)/2;
while(que1.size())
{
int tmp=que1.top();
que1.pop();

if(b[tmp]<=0)
{
for(int j=0;j<k;j++)
{
b[tmp+a[j]]++;
}
a[k++]=tmp;
if(k==len) break;
}
else
{
b[tmp]--;
}
}
printf("%d\n",len);
for(int i=0;i<len;i++)
{
if(i==0)printf("%d",a[i]);
else printf(" %d",a[i]);
}
printf("\n");

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  2017多校 acm hdu