您的位置:首页 > 其它

POJ - 1163:The Triangle

2017-08-22 17:54 225 查看
7

3   8

8   1   0

2   7   4   4

4   5   2   6   5

(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left
or diagonally down to the right.
Input
Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1
but <= 100. The numbers in the triangle, all integers, are between 0 and 99.
Output
Your program is to write to standard output. The highest sum is written as an integer.
Sample Input
5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
Sample Output

30
Sample Code

//版本1
#include<cstdio>
#include <algorithm>
using namespace std;

const int maxn=100+10;
int arr[maxn][maxn],maxSum[maxn][maxn];
int n;

int getMaxSum(int x,int y)
{
if(maxSum[x][y]!=-1)
return maxSum[x][y];
if(x==n)
maxSum[x][y]=arr[x][y];
else
{
int l=getMaxSum(x+1,y);
int r=getMaxSum(x+1,y+1);
maxSum[x][y]=max(l,r)+arr[x][y];
}
return maxSum[x][y];
}

int main()
{
scanf("%d",&n);
for(int i=1;i<=n;i++)
{
for(int j=1;j<=i;j++)
{
scanf("%d",&arr[i][j]);
maxSum[i][j]=-1;
}

}
printf("%d\n",getMaxSum(1,1));
}
//版本2
#include<cstdio>
#include <algorithm>
using namespace std;

const int maxn=100+10;
int arr[maxn][maxn],maxSum[maxn][maxn];
int n;

int main()
{
scanf("%d",&n);
for(int i=1;i<=n;i++)
for(int j=1;j<=i;j++)
scanf("%d",&arr[i][j]);

for(int i=n;i>=1;i--)
{
for(int j=1;j<=i;j++)
{
if(i==n)
maxSum[i][j]=arr[i][j];
else
maxSum[i][j]=max(maxSum[i+1][j],maxSum[i+1][j+1])+arr[i][j];
}
}
printf("%d\n",maxSum[1][1]);
}
//版本3
#include<cstdio>
#include <algorithm>
using namespace std;

const int maxn=100+10;
int arr[maxn][maxn];
int n;

int main()
{
scanf("%d",&n);
for(int i=1;i<=n;i++)
for(int j=1;j<=i;j++)
scanf("%d",&arr[i][j]);

int *p=arr
;

for(int i=n-1;i>=1;i--)
for(int j=1;j<=i;j++)
p[j]=max(p[j],p[j+1])+arr[i][j];

printf("%d\n",p[1]);
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: