您的位置:首页 > 其它

HDU 1686 Oulipo (KMP查找可交叉区间模式串)

2017-08-22 15:28 399 查看
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e’. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive ‘T’s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A’, ‘B’, ‘C’, …, ‘Z’} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).

One line with the text T, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3

BAPC

BAPC

AZA

AZAZAZA

VERDI

AVERDXIVYERDIAN

Sample Output

1

3

0

唯一的修改就是在返回位置的地方修改为j=f[j]

#include <string.h>
#include <iostream>
#include <cstdio>
#define maxn 1000010
int next[maxn];
void getNext(char* P, int* f)
{
int m = strlen(P);
f[0] = 0;
f[1] = 0;
for(int i = 1; i < m; i++)
{
int j = f[i];
while(j && P[i] != P[j])
{
j = f[j];
}
f[i + 1]=P[i]==P[j]?j+1:0;
}
}

int kmp(char* T, char*P, int*f)
{
int n = strlen(T), m = strlen(P);
getNext(P, f);
int ans=0;
int j = 0;
for(int i = 0; i < n; i++)
{
while(j && P[j] != T[i])
{
j = f[j];
}
if(P[j] == T[i])
{
j++;
}
if(j == m)
{
ans++;//i-m+1
j=f[j];
}
}
return ans;
}
int main()
{
char s1[maxn];
char s2[maxn];
int a;
int n;
int m;
int t;
scanf("%d",&t);
while(t--)
{
scanf("%s%s",s2,s1);
int a=kmp(s1,s2,next);
printf("%d\n",a);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: