您的位置:首页 > 产品设计 > UI/UE

HDU 1711 Number Sequence (KMP模板)

2017-08-22 15:25 344 查看
Given two sequences of numbers : a[1], a[2], …… , a
, and b[1], b[2], …… , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], …… , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], …… , a
. The third line contains M integers which indicate b[1], b[2], …… , b[M]. All integers are in the range of [-1000000, 1000000].

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

Sample Input

2

13 5

1 2 1 2 3 1 2 3 1 3 2 1 2

1 2 3 1 3

13 5

1 2 1 2 3 1 2 3 1 3 2 1 2

1 2 3 2 1

Sample Output

6

-1

#include <string.h>
#include <iostream>
#include <cstdio>
#define maxn 1000010
int next[maxn];
int n,m;
void getNext(int* P, int* f)
{
f[0] = 0;
f[1] = 0;
for(int i = 1; i < m; i++)
{
int j = f[i];
while(j && P[i] != P[j])
{
j = f[j];
}
f[i + 1]=P[i]==P[j]?j+1:0;
}
}

int kmp(int* T, int* P, int*f)
{
getNext(P, f);
int j = 0;
for(int i = 0; i < n; i++)
{
while(j && P[j] != T[i])
{
j = f[j];
}
if(P[j] == T[i])
{
j++;
}
if(j == m)
{
return i-m+2;
}
}
return -1;
}
int main()
{
int s1[maxn];
int s2[maxn];
int a;
int t;
scanf("%d",&t);
while(t--)
{scanf("%d%d",&n,&m);
if(m>n)
{
puts("-1");
continue;
}
for(int i=0;i<n;i++)
{
scanf("%d",&s1[i]);
}
for(int i=0;i<m;i++)
{
scanf("%d",&s2[i]);
}
int a=kmp(s1,s2,next);
printf("%d\n",a);

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: