您的位置:首页 > 其它

POJ——T 1988 Cube Stacking

2017-08-22 14:44 405 查看

http://poj.org/problem?id=1988

Time Limit: 2000MS   Memory Limit: 30000K
Total Submissions: 25865   Accepted: 9044
Case Time Limit: 1000MS

Description

Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations: 
moves and counts. 
* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y. 
* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value. 

Write a program that can verify the results of the game. 

Input

* Line 1: A single integer, P 

* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a 'M' for a move operation or a 'C' for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X. 

Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself. 

Output

Print the output from each of the count operations in the same order as the input file. 

Sample Input

6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4

Sample Output

1
0
2

Source

USACO 2004 U S Open   查询x时,先维护x下边的、
#include <algorithm>
#include <cstdio>

using namespace std;

const int N(30005);
int fa
,sum
,beh
;

int find(int x)
{
if(fa[x]==x) return x;
int dad=find(fa[x]);
beh[x]+=beh[fa[x]];
return fa[x]=dad;
}
inline void combine(int x,int y)
{
x=find(x),y=find(y);
if(x==y) return ;
beh[x]+=sum[y];
sum[y]+=sum[x];
fa[x]=y;
}

int main()
{
for(int i=1;i<N;i++)
fa[i]=i,sum[i]=1;
int p,u,v; scanf("%d",&p);
for(char ch;p--;)
{
scanf("\n%c%d",&ch,&u);
if(ch=='M')
{
scanf("%d",&v);
combine(u,v);
}
else find(u),printf("%d\n",beh[u]);
}
return 0;
}

 

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: