您的位置:首页 > 其它

bzoj 1677: [Usaco2005 Jan]Sumsets 求和(DP)

2017-08-22 11:58 435 查看

1677: [Usaco2005 Jan]Sumsets 求和

Time Limit: 5 Sec  Memory Limit: 64 MB
Submit: 1012  Solved: 592

[Submit][Status][Discuss]

Description

Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the
possible sets of numbers that sum to 7: 1) 1+1+1+1+1+1+1 2) 1+1+1+1+1+2 3) 1+1+1+2+2 4) 1+1+1+4 5) 1+2+2+2 6) 1+2+4 Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000).
给出一个N(1≤N≤10^6),使用一些2的若干次幂的数相加来求之.问有多少种方法

Input

   一个整数N.

Output

方法数.这个数可能很大,请输出其在十进制下的最后9位.

Sample Input

7

Sample Output

6

DP,直接上公式



其中右边括号是艾佛森约定,'|'是整除记号

这样不会重复

#include<stdio.h>
#define mod 1000000000
int er[21] = {1,2}, dp[1000005] = {1,1};
int main(void)
{
int n, i, j;
for(i=2;i<=20;i++)
er[i] = er[i-1]*2;
for(i=2;i<=1000000;i++)
{
for(j=0;er[j]<=i;j++)
{
if((i-er[j])%er[j]==0)
dp[i] = (dp[i]+dp[(i-er[j])/er[j]])%mod;
}
}
while(scanf("%d", &n)!=EOF)
printf("%d\n", dp
);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: