您的位置:首页 > 其它

LightOJ - 1370 Bi-shoe and Phi-shoe (欧拉函数,素数打表)

2017-08-21 21:26 627 查看
原题:



Bamboo Pole-vault is a massively popular sport in Xzhiland. And Master Phi-shoe is a very popular coach for his success. He needs some bamboos for his students, so he asked his assistant Bi-Shoe to go to the market and buy them. Plenty of Bamboos of all
possible integer lengths (yes!) are available in the market. According to Xzhila tradition,

Score of a bamboo = Φ (bamboo's length)

(Xzhilans are really fond of number theory). For your information, Φ (n) = numbers less than n which are relatively prime (having no common divisor other than 1) to n. So, score of a bamboo of length 9 is
6 as 1, 2, 4, 5, 7, 8 are relatively prime to 9.

The assistant Bi-shoe has to buy one bamboo for each student. As a twist, each pole-vault student of Phi-shoe has a lucky number. Bi-shoe wants to buy bamboos such that each of them gets a bamboo with a score greater than or equal to his/her lucky number.
Bi-shoe wants to minimize the total amount of money spent for buying the bamboos. One unit of bamboo costs 1 Xukha. Help him.

Input
Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 10000) denoting the number of students of Phi-shoe. The next line contains n space separated integers denoting the lucky numbers for the students. Each lucky
number will lie in the range [1, 106].

Output
For each case, print the case number and the minimum possible money spent for buying the bamboos. See the samples for details.

Sample Input
3

5

1 2 3 4 5

6

10 11 12 13 14 15

2

1 1

Sample Output
Case 1: 22 Xukha

Case 2: 88 Xukha

Case 3: 4 Xukha

题意:

       给定n个数,寻找欧拉函数值大于等于n个数的数之和。

思路:

      素数p的欧拉函数值为p-1,则可以从n+1开始找,最近的一个素数一定是欧拉函数值最接近n的数。

#include <iostream>
#include <iomanip>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <queue>
#include <deque>
#include <string>
#include <cmath>
#include <vector>
#include <utility>
#include <set>
#include <map>
#include <sstream>
#include <climits>
//#pragma comment(linker, "/STACK:1024000000,1024000000")
#define pi acos(-1.0)
#define INF 2147483647
using namespace std;
typedef long long ll;
typedef pair <int,int > P;
int pri[1000050];
int t,n;
int a[10005];

void prime()
{
for(int i = 2 ; i < 1000050 ; i++)
{
if(!pri[i])
{
for(int j = i + i ; j <= 1000050; j += i)
pri[j] = 1;
}
}
}
int main()
{
prime();
scanf("%d",&t);
for(int k=1;k<=t;k++)
{
sc
4000
anf("%d",&n);
for(int i=0;i<n;i++)
scanf("%d",&a[i]);
ll res=0;
for(int i=0;i<n;i++)
{
for(int j=a[i]+1;;j++)
if(!pri[j])
{
res+=j;
break;
}
}
printf("Case %d: %lld Xukha\n",k,res);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: