您的位置:首页 > 其它

HDOJ1208 记忆化搜索水题

2017-08-21 21:25 417 查看
Pascal’s Travels

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 2575 Accepted Submission(s): 1221

Problem Description

An n x n game board is populated with integers, one nonnegative integer per square. The goal is to travel along any legitimate path from the upper left corner to the lower right corner of the board. The integer in any one square dictates how large a step away from that location must be. If the step size would advance travel off the game board, then a step in that particular direction is forbidden. All steps must be either to the right or toward the bottom. Note that a 0 is a dead end which prevents any further progress.

Consider the 4 x 4 board shown in Figure 1, where the solid circle identifies the start position and the dashed circle identifies the target. Figure 2 shows the three paths from the start to the target, with the irrelevant numbers in each removed.

Figure 1

Figure 2

Input

The input contains data for one to thirty boards, followed by a final line containing only the integer -1. The data for a board starts with a line containing a single positive integer n, 4 <= n <= 34, which is the number of rows in this board. This is followed by n rows of data. Each row contains n single digits, 0-9, with no spaces between them.

Output

The output consists of one line for each board, containing a single integer, which is the number of paths from the upper left corner to the lower right corner. There will be fewer than 2^63 paths for any board.

Sample Input

4

2331

1213

1231

3110

4

3332

1213

1232

2120

5

11101

01111

11111

11101

11101

-1

Sample Output

3

0

7

Hint

Hint

Brute force methods examining every path will likely exceed the allotted time limit.

64-bit integer values are available as “__int64” values using the Visual C/C++ or “long long” values

using GNU C/C++ or “int64” values using Free Pascal compilers.

Source

Mid-Central USA 2005

Recommend

mcqsmall | We have carefully selected several similar problems for you: 1074 1072 1180 1195 1045

写了一个非常标准的记忆化搜索程序

#include <iostream>
#include <cmath>
#include <cstring>
#include <cstdio>
using namespace std;

const int maxn = 40;
int n,i,j,k,a[maxn][maxn];
long long  dp[maxn][maxn];

void init(){
char str[50];
getchar();
for (i=1; i<=n; i++){
gets(str);
for (j=1; j<=n; j++) a[i][j] = str[j-1] - '0';
}

for (i=1; i<=n; i++)
for (j=1; j<=n; j++)
dp[i][j] = 0;
dp

= 1;
}

long long dfs(int x, int y){
if (dp[x][y]) return dp[x][y];
if (a[x][y]==0) return 0;
if (x+a[x][y]<=n) dp[x][y] += dfs(x+a[x][y],y);
if (y+a[x][y]<=n) dp[x][y] += dfs(x,a[x][y]+y);
return dp[x][y];
}

int main(){
while (scanf("%d",&n)!=EOF) {
if (n==-1) break;
init();
cout << dfs(1,1) << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: