您的位置:首页 > 其它

ZOJ - 3607 Lazier Salesgirl(模拟)

2017-08-21 19:16 393 查看
Lazier Salesgirl
Time Limit: 2 Seconds      Memory Limit: 65536 KB
Kochiya Sanae is a lazy girl who makes and sells bread. She is an expert at bread making and selling. She can sell the i-th customer a piece of bread for price pi.
But she is so lazy that she will fall asleep if no customer comes to buy bread for more than w minutes. When she is sleeping, the customer coming to buy bread will leave immediately. It's known that she starts to sell bread now and the i-th
customer come after ti minutes. What is the minimum possible value of w that maximizes the average value of the bread sold?

Input

There are multiple test cases. The first line of input is an integer T ≈ 200 indicating the number of test cases.
The first line of each test case contains an integer 1 ≤ n ≤ 1000 indicating the number of customers. The second line contains n integers 1 ≤ pi ≤
10000. The third line contains nintegers 1 ≤ ti ≤ 100000. The customers are given in the non-decreasing order of ti.

Output

For each test cases, output w and the corresponding average value of sold bread, with six decimal digits.

Sample Input

2
4
1 2 3 4
1 3 6 10
4
4 3 2 1
1 3 6 10

Sample Output

4.000000 2.500000
1.000000 4.000000


题意:有一家面包店,接下来的第 t[i] 分钟会有一位客人来以 p[i] 的价格买走一块面包,但面包店只要超过 w 分钟没有顾客光临,老板就会睡着,

之后来的客人就买不了面包了,问在保证卖出的面包的平均价格尽量高的情况下 w 的最小值是多少


思路:由于数据范围不大,我们只需要暴力枚举每一个合法的老板有可能睡着的时间点 t[i] 即可。何谓合法的时间点?即到这一时刻之前

t[j] - t[j-1]的最大值必定要小于 t[i+1] - t[i]。(保证在这个时间点之前没睡着,且在下一位客人到来之前睡着)


#include <bits/stdc++.h>
using namespace std;

const int N = 1e4 + 10;
int t, n;
double p
, v
, vv
;
struct xx{
double p, v;
int n;
}a
;

bool cmp(xx a, xx b){
if(a.p == b.p) return a.v < b.v;
return a.p > b.p;
}

int main(){
scanf("%d", &t);
while(t--){
scanf("%d", &n);
double sum = 0, maxi = 0;
int ii = 0;
for(int i = 1; i <= n; i++){
scanf("%lf", &p[i]);
p[i] += p[i-1];
}
for(int i = 1; i <= n; i++){
scanf("%lf", &v[i]);
double tmp = v[i]-v[i-1];
vv[i] = max(vv[i-1], tmp);
}
v[n+1] = 0x3f3f3f3f;
int x = 0;
for(int i = 1; i <= n; i++){
if(vv[i] < v[i+1]- v[i]){

4000
a[x].v = vv[i];
a[x].p = p[i]/i*1.0;
x++;
}
}
sort(a, a+x, cmp);
printf("%.6f %.6f\n", a[0].v, a[0].p);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: