您的位置:首页 > 其它

Add More Zero

2017-08-21 15:56 260 查看
There is a youngster known for amateur propositions concerning several mathematical hard problems. 

Nowadays, he is preparing a thought-provoking problem on a specific type of supercomputer which has ability to support calculations of integers between 00 and (2m−1)(2m−1) (inclusive). 

As a young man born with ten fingers, he loves the powers of 1010 so
much, which results in his eccentricity that he always ranges integers he would like to use from 11 to 10k10k (inclusive). 

For the sake of processing, all integers he would use possibly in this interesting problem ought to be as computable as this supercomputer could. 

Given the positive integer mm,
your task is to determine maximum possible integer kkthat
is suitable for the specific supercomputer.

InputThe input contains multiple test cases. Each test case in one line contains only one positive integer mm,
satisfying 1≤m≤1051≤m≤105.
OutputFor each test case, output " Case #xx: yy"
in one line (without quotes), where xxindicates
the case number starting from 11 and yy denotes
the answer of corresponding case.
Sample Input
1
64


Sample Output
Case #1: 0
Case #2: 19

题意:输入一个数m,求0到2^m-1范围内,使得10^k最大,求k思路:10^k<=2^m-1 10^k<2^m 取对数 log10^k<log2^m k<m*log2/log10 k<m*log10(2)

#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
const double IP=0.30102999566398;
int main()
{
int n,m,cas=1;
while(~scanf("%d",&n))
{
int m=(int)(n*IP);
printf("Case #%d: %d\n",cas++,m);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: