您的位置:首页 > 其它

【lightoj 1214】Large Division (大数除法)

2017-08-21 10:35 531 查看


Large Division

 

Given two integers, a and b, you should check whether a is divisible by b or not. We know that an integer a is divisible by an integer b if and only if
there exists an integer c such that a = b * c.

Input
Input starts with an integer T (≤ 525), denoting the number of test cases.

Each case starts with a line containing two integers a (-10200 ≤ a ≤ 10200) and b (|b| > 0, b fits into a 32 bit signed integer). Numbers will not contain leading zeroes.

Output
For each case, print the case number first. Then print 'divisible' if a is divisible by b. Otherwise print 'not divisible'.

Sample Input
6

101 101

0 67

-101 101

7678123668327637674887634 101

11010000000000000000 256

-202202202202000202202202 -101

Sample Output
Case 1: divisible

Case 2: divisible

Case 3: divisible

Case 4: not divisible

Case 5: divisible

Case 6: divisible

代码:
#include<cstdio>
#include<cstring>
typedef __int64 LL;
LL b;
int t;
char a[205];
int main()
{
scanf("%d",&t);
int cs=1;
while(t--)
{
scanf("%s%lld",a,&b);
int l=strlen(a);
LL ans=0;
for(int i=0;i<l;i++)
{
if(a[i]=='-') continue;
ans=(ans*10-(a[i]-'0'))%b;
}
if(ans==0) printf("Case %d: divisible\n",cs++);
else printf("Case %d: not divisible\n",cs++);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: